Sign in with
Sign up | Sign in
Your question

I get black screen after putting in new video card

Last response: in Graphics & Displays
Share
December 23, 2012 9:34:52 PM

Hello, I just put in my nvidia 560 gtx video card and everything loads up until after the windows xp load screen, after that, it just goes black but the computer is still on but nothing is being displayed. So I put back my old video card (ati hd 5450) and now the same thing is happening and whenever i try to go through safe mode, it just freezes... Please help please
a b U Graphics card
December 23, 2012 9:44:16 PM

Make sure that the power connectors are in their proper place and make sure the card is really fit into the PCI-E slot and doesn't move forward or backward.
m
0
l
December 23, 2012 9:49:29 PM

Yes, I did all that but still have the same problem :(  and even my old video card does the same thing now too.
m
0
l
Related resources
a b U Graphics card
December 23, 2012 9:52:26 PM

Can you get a picture of the current setup you have and post it here? Maybe you are missing something. Under worst conditions, you might have ruined something on the motherboard, lets hope not.
m
0
l
December 23, 2012 10:03:40 PM

Yes, ill take a picture right now and post it
m
0
l
a b U Graphics card
December 23, 2012 10:03:55 PM

Best thing to do is clear the cmos by removing the battery and switching the jumper then putting the jumper back and restarting with no card then shutting it down and inserting the card . Have this problem in my IT class sometimes and I tell everyone to try it and it works. That or try another pcie slot if it still doesn't work
m
0
l
December 23, 2012 10:08:10 PM

When you say jumper, what do you mean by that? I know what youre talking about for the battery...
m
0
l
December 23, 2012 10:11:02 PM

06yfz450ridr said:
Best thing to do is clear the cmos by removing the battery and switching the jumper then putting the jumper back and restarting with no card then shutting it down and inserting the card . Have this problem in my IT class sometimes and I tell everyone to try it and it works. That or try another pcie slot if it still doesn't work



I understand what you're saying when you say battery but what do you mean by jumper? would you be able to show me please...
m
0
l
!