Theme Hospital problem

Archived from groups: microsoft.public.windowsxp.games (More info?)

Hi

Running WinXPHome SP2.

Have Theme Hospital loaded to C:\Program Files\Bullfrog\Hospital, with
Shortcuts on various desktops.

Game runs OK with all users, but only users with Administrator rights can
save games. Using 95 or 98 Compatibility Modes doesn't alter situation.

Anyone have any ideas? My kids (limited users) would be grateful!

TIA

Envo
6 answers Last reply
More about theme hospital problem
  1. Archived from groups: microsoft.public.windowsxp.games (More info?)

    Try checking the security permissions on the game directory. It's quite
    possible that they do not have write access, IIRC only administrators
    do by default.

    Paul Smith wrote:
    > "Envo" <awne16325@spamgapblueyonder.co.uk> wrote in message
    > news:2Lf%d.2000$Ab.919@text.news.blueyonder.co.uk...
    >
    > > Have Theme Hospital loaded to C:\Program Files\Bullfrog\Hospital,
    with
    > > Shortcuts on various desktops.
    > >
    > > Game runs OK with all users, but only users with Administrator
    rights can
    > > save games. Using 95 or 98 Compatibility Modes doesn't alter
    situation.
    > >
    > > Anyone have any ideas? My kids (limited users) would be grateful!
    >
    > This is likely a limitation of the game itself... Back when it was
    made
    > everyone had admin rights on Windows. There's no solution as such
    only a
    > work-around, the one below by Jimmy S.
    >
    > Basically what this will do is enable them to run the game as an
    admin
    > user - but prevent them from actually logging on as an admin.
    >
    > How to Create a Secure Admin Account for use with the Run As...
    Command
    >
    > 1. Click Start / Control Panel / User Accounts / Create a New
    Account /
    > Name the Account: "able2play" (without quotes) / Next Pick:
    > "Computer-Administrator" & Click "Create Account";
    >
    > 2. Click on your new able2play account and Create a Password for it;
    >
    > 3. When your limited user wants to play a game that requires
    Administrator
    > privileges they can Right-Click the shortcut to that game / Click Run
    As...
    > / "The Following User": able2play and enter the password.
    >
    > Steps 4 and 5 are optional, and are to prevent a user from logging on
    to the
    > computer as an administrator using the able2play account and
    password:
    >
    > 4. Remove "able2play" from the Welcome screen: Save and run my
    registry
    > patch which will add able2play to the hidden user list in your
    Windows XP
    > registry:
    > able2play.reg (Save and then Open).
    > or
    > * To avoid the above patch, run regedt32, browse to
    > [HKLM\SOFTWARE\Microsoft\Windows
    > NT\CurrentVersion\Winlogon\SpecialAccounts\UserList]Click Edit / New
    / Dword
    > value / ValueName: able2play / Value Data: 0 (hex)
    >
    > 5. This step will force the able2play account to logoff if anyone
    logs on
    > with it. What I do is add a shortcut to the windows logoff routine
    into the
    > RUN key of the able2play registry. Again, I made a registry patch to

    > simplify this process:
    >
    > 5a. <ONLY RUN THIS PATCH USING THE ABLE2PLAY ACCOUNT> Click and Save
    this
    > patch to the Local Disk (C:) Drive DO NOT OPEN IT
    >
    (http://windows.dasmirnov.net/downloads/OnlyRunUsingAble2PlayAccount.reg)
    >
    >
    > 5b. Click Start / Log off / Click a blank area on the right side of
    the
    > Welcome screen, and then press CTRL+ALT+DELETE to logon the able2play

    > account. Now, double click the patch from step 5a, install it,
    delete it,
    > and then Logoff.
    > or
    > * To avoid using the registry patch, click Start / Run / regedt32
    /
    > browse to: [HKCU\SOFTWARE\ Microsoft\Windows\CurrentVersion\Run] and
    Click
    > Edit / New / String value / ValueName: logoff / Value data: logoff
    REMEMBER:
    > Only create this auto logoff while logged on as able2play!
    >
    >
    > --
    > Paul Smith,
    > Yeovil, UK.
    > http://www.dasmirnov.net/
    > http://windows.dasmirnov.net/ Windows XP Resource Site.
    >
    > *Replace nospam with smirnov to reply by e-mail*
  2. Archived from groups: microsoft.public.windowsxp.games (More info?)

    "Envo" <awne16325@spamgapblueyonder.co.uk> wrote in message
    news:2Lf%d.2000$Ab.919@text.news.blueyonder.co.uk...

    > Have Theme Hospital loaded to C:\Program Files\Bullfrog\Hospital, with
    > Shortcuts on various desktops.
    >
    > Game runs OK with all users, but only users with Administrator rights can
    > save games. Using 95 or 98 Compatibility Modes doesn't alter situation.
    >
    > Anyone have any ideas? My kids (limited users) would be grateful!

    This is likely a limitation of the game itself... Back when it was made
    everyone had admin rights on Windows. There's no solution as such only a
    work-around, the one below by Jimmy S.

    Basically what this will do is enable them to run the game as an admin
    user - but prevent them from actually logging on as an admin.

    How to Create a Secure Admin Account for use with the Run As... Command

    1. Click Start / Control Panel / User Accounts / Create a New Account /
    Name the Account: "able2play" (without quotes) / Next Pick:
    "Computer-Administrator" & Click "Create Account";

    2. Click on your new able2play account and Create a Password for it;

    3. When your limited user wants to play a game that requires Administrator
    privileges they can Right-Click the shortcut to that game / Click Run As...
    / "The Following User": able2play and enter the password.

    Steps 4 and 5 are optional, and are to prevent a user from logging on to the
    computer as an administrator using the able2play account and password:

    4. Remove "able2play" from the Welcome screen: Save and run my registry
    patch which will add able2play to the hidden user list in your Windows XP
    registry:
    able2play.reg (Save and then Open).
    or
    * To avoid the above patch, run regedt32, browse to
    [HKLM\SOFTWARE\Microsoft\Windows
    NT\CurrentVersion\Winlogon\SpecialAccounts\UserList]Click Edit / New / Dword
    value / ValueName: able2play / Value Data: 0 (hex)

    5. This step will force the able2play account to logoff if anyone logs on
    with it. What I do is add a shortcut to the windows logoff routine into the
    RUN key of the able2play registry. Again, I made a registry patch to
    simplify this process:

    5a. <ONLY RUN THIS PATCH USING THE ABLE2PLAY ACCOUNT> Click and Save this
    patch to the Local Disk (C:) Drive DO NOT OPEN IT
    (http://windows.dasmirnov.net/downloads/OnlyRunUsingAble2PlayAccount.reg)


    5b. Click Start / Log off / Click a blank area on the right side of the
    Welcome screen, and then press CTRL+ALT+DELETE to logon the able2play
    account. Now, double click the patch from step 5a, install it, delete it,
    and then Logoff.
    or
    * To avoid using the registry patch, click Start / Run / regedt32 /
    browse to: [HKCU\SOFTWARE\ Microsoft\Windows\CurrentVersion\Run] and Click
    Edit / New / String value / ValueName: logoff / Value data: logoff REMEMBER:
    Only create this auto logoff while logged on as able2play!


    --
    Paul Smith,
    Yeovil, UK.
    http://www.dasmirnov.net/
    http://windows.dasmirnov.net/ Windows XP Resource Site.

    *Replace nospam with smirnov to reply by e-mail*
  3. Archived from groups: microsoft.public.windowsxp.games (More info?)

    "DosFreak" <d0sfreak@yahoo.com> wrote in message
    news:1111352929.804772.166810@g14g2000cwa.googlegroups.com...
    > Try checking the security permissions on the game directory. It's quite
    > possible that they do not have write access, IIRC only administrators
    > do by default.

    I didn't think Home allowed such fine control of permissions?

    --
    Paul Smith,
    Yeovil, UK.
    http://www.dasmirnov.net/
    http://windows.dasmirnov.net/ Windows XP Resource Site.

    *Replace nospam with smirnov to reply by e-mail*
  4. Archived from groups: microsoft.public.windowsxp.games (More info?)

    It should, it's possible that XP Home like XP Pro has "Simple File
    Sharing" enabled by default which hides the Security Tab /sarcasm
    Thanks MS!/sarcasm I've personally never used XP Home but I find it
    highly doubtfull that MS would remove access to such a basic function
    of NTFS. I'll see if I can load my copy of XP Home under VPC and check
    it out.


    Paul Smith wrote:
    > "DosFreak" <d0sfreak@yahoo.com> wrote in message
    > news:1111352929.804772.166810@g14g2000cwa.googlegroups.com...
    > > Try checking the security permissions on the game directory. It's
    quite
    > > possible that they do not have write access, IIRC only
    administrators
    > > do by default.
    >
    > I didn't think Home allowed such fine control of permissions?
    >
    > --
    > Paul Smith,
    > Yeovil, UK.
    > http://www.dasmirnov.net/
    > http://windows.dasmirnov.net/ Windows XP Resource Site.
    >
    > *Replace nospam with smirnov to reply by e-mail*
  5. Archived from groups: microsoft.public.windowsxp.games (More info?)

    "DosFreak" <d0sfreak@yahoo.com> wrote in message
    news:1111546055.962428.313040@z14g2000cwz.googlegroups.com...
    > see if I can load my copy of XP Home under VPC and check
    > it out.

    Please do and let me know. 8-)

    --
    Paul Smith,
    Yeovil, UK.
    http://www.dasmirnov.net/
    http://windows.dasmirnov.net/ Windows XP Resource Site.

    *Replace nospam with smirnov to reply by e-mail*
  6. Archived from groups: microsoft.public.windowsxp.games (More info?)

    Found it:
    http://www.experts-exchange.com/Operating_Systems/WinXP/Q_21046791.html

    "Simple File Sharing is enabled by default and you cannot disable it in
    Home Edition... but if you want to add the Security Tab to your Home
    edition folders, here is one method that I have seen used:

    Adding the Security Tab for W XP Home edition:

    Go
    to:http://www.microsoft.com/ntserver/nts/downloads/recommended/scm/default.asp

    Instructions: Download the x86 (Intel) version of the Security
    Configuration Manager and save it to your hard disk. Double click the
    SCESP4I.EXE file you downloaded and extract the contents to a temporary
    location on your hard disk. Then open the folder you extracted the
    files to and locate the Setup.inf (Setup Information) file. Right
    click Setup.inf and select Install. After the installation is
    finished, reboot your computer.

    Disclaimer: I have tested this procedure on my XP Home installation,
    and it works. I cannot guarantee that it will work on your system.
    Make sure you create a System Restore point before proceeding."


    It works. Only problem I don't like about this method is that it
    applies 1998 NT4 security policies to XP. The "Simple File Sharing"
    dialog is still gone but the Security tab shows up. Going to try out
    the different security policies in XP and see if they have the same
    effect. Since the functionality is there and it's enabled in such an
    old policy then it should be easy to narrow it down.
Ask a new question

Read More

Games Microsoft Compatibility Windows XP