IDE drive DOS mode

Hi all,

My system, all of a sudden, started to boot and run in DOS-compatibility mode - sometimes. Sometimes it doesn't, and all is neat and nice. Sometimes it will switch between DOS-compat. and normal mode when beeing warm rebooted, sometimes it won't. No further effects are noticable for me, I also cannot see any systematical cause in this DOS-on-off-behaviour. I didn't install any system-related software for months now. I haven't changed system settings either. When DOS-mode is active, in the system-hardware manager I get an error code , 10 I believe, for the primary IDE driver, it should be changed for an actual version, or that the hardware component is not active. But when trying to reinstall a newer version from CD or web via the button in this info window, I get a message that the drivers are top actual and will not be changed, then the process is brought to an end. Rebooting one or two times normally switch into normal mode again, but also: sometimes it will switch from normal to compat.-mode. As far as I can see, anything else works fine, even the compat.-mode doesn'T seem to trigger any negative side effects.

Hm, any advise or help? I am no computer insider, so please put it as simple as possible.

Thanks, Skybird

Win98SE, DirX8.0a, Piii/450, 128 MB, TNT2M64
16 answers Last reply
More about drive mode
  1. Check if there are no resource conflicts between your components, and which motherboard do you have?

    My case has so many fans that it hovers above the ground :eek: .
  2. Hm, when the DOS-compat.-mode is active, there is a ressource conflict message for the first IDE drive as I described, if I remember correctly it says error 10 and updating the driver for that device is necessary. That message is not there, when DOS-compat-mode is not active. I am wondering why it is activating itself sometimes, sometimes not? I found no other trouble with my harddrive, so I still don't think it to be broken in technical-hardware-terms.
    Motherboard, according to the bill, Tekram BX P6B40-A4-100 MHz.
  3. Can you post your IRQ usage?

    :cool: <b><font color=blue>The Cisco Kid</font color=blue></b> :cool:
  4. What you mean? As I said, I am no computer insider... Sorry if I ask stupid questions :) If you mean my email, it's +deleted+

    <P ID="edit"><FONT SIZE=-1><EM>Edited by Skybird on 02/03/02 05:49 AM.</EM></FONT></P>
  5. Okay, First delete that last post, by going onto the "edit" button and taking the delete option. Your e-mail is safe so far. You don't want spam do you?

    Right.

    Right click "My computer", and pick "properties" and then go to the "device manager" tab.

    Double left click on "computer" and you will see a list of numbers against devices or "settings" against "hardware using the setting".

    Post all the info you see to the forum.

    e.g 00 - system timer
    01 - etc etc

    This will tell us if you might have a device conflict in your system.

    :cool: <b><font color=blue>The Cisco Kid</font color=blue></b> :cool:
  6. I finally managed to recognize the difference between IRQ and ICQ , hiph hipp hooray!

    Here we go, and btw. thanks for your willingness to help.

    00 Systemzeitgeber (system timer)
    01 Standard (101/102 Tasten) oder Microsoft Natural Keyboard
    02 Programmierbarer Interrupt-Controller
    03 COM Anschluss (COM2)
    04 Microlink 56k
    04 COM Anschluss (COM1)
    05 ES1398 PCI AudioDrive
    06 standard Diskettenlaufwerk-Controller (discdrive controller)
    07 Epson Printer Port (LPT1)
    08 CMOS-/Echtzeitsystemuhr (realtime system clock)
    10 Intel 82371AB/EB PCI/USB Universal Host Controller
    10 IRQ Holder für PCI-Steuerung
    11 NVIDIA RIVA TNT2 Model 64/Model 64 Pro
    11 IRQ-Holder für PCI-Steuerung
    12 PS/2-kompatibler Mausanschluss (mouse port)
    13 Numerischer Coprozessor
    14 Intel 83271AB/EB PCI Bus Master IDE Controller
    14 Erster IDE Controller (Dual FIFO) (1. Controller)
    15 Intel 83271AB/EB PCI Bus Master IDE Controller
    15 Zweiter IDE Controller (Dual FIFO) (2. Controller)

    That's it. What now?
  7. There doesn't seem to be any IRQ conflicts, can you post your DMA usage, you can find it with the same way you found the IRQ setting, but then you choose DMA instead of IRQ.

    My case has so many fans that it hovers above the ground :eek: .
  8. Your wish is my command:

    01 ES1938 DOS Emulation
    02 Standard-Diskettenlaufwerk-Controller
    03 Epson Printer Port (LPT1)
    04 DMA-Controller

    The system currently is running in DOS-compatibility-mode. Although a yellow marker appeared in device manager/harddrivecontroller/first IDE Controller (Dual FIFO), Clicking on that and then "Ressources" beyond the window with ressource-types and settings there is a small window saying "no conflicts".
  9. If you don't play DOS games, you can disable the DOS emulation. This can be done under Control Panal - System - [soundcard] - [device called sb16 emualtion or something like that] - properties - disable in current hardware profile. This might help to solve the problem.

    My case has so many fans that it hovers above the ground :eek: .
  10. Ooops, somehow connection was lost, so I type it a second time...

    Just tried your advise, unfortunately without success. If I got it correctly, the problem will "only" reduce the effectiveness/speed of my HD. It seems, I have to live with that, and the probelm fortunately isn't affecting my system in any other way, it seems.

    So, anyway thanks for your willingness to help. Have a nice day,

    Skybird
  11. Have you already tried this driver? It is the latest Intel Busmaster Driver:
    <A HREF="http://ftp://ftp.tekram.com.tw/Mainboard/Intel chipset/P6/B40/P6B40-A4X/Driver&AP/ChipSet/IDEBusMaster.ZIP" target="_new">http://ftp://ftp.tekram.com.tw/Mainboard/Intel chipset/P6/B40/P6B40-A4X/Driver&AP/ChipSet/IDEBusMaster.ZIP</A>.

    My case has so many fans that it hovers above the ground :eek: .
  12. I'm not crazy enough to flash the BIOS without knowing what I'm actually doing. I was only user with computers, no system and tech stuff insider. Since the system ran well for two years, it should be able to do that with the older driver. The problem appeared by it's own, why should the driver and BIOS all of a sudden brake down? If the old ones doesn't work any longer without beeing harmed, then probably I have to admit that I do have a hardware defect instead. Or am I wrong here? Last software installation was weeks before the first appearance of the problem.

    Anyway, I looked at Tekram'S website, but it was hardcore tech, even my mainboard's type was seperated into two sub-categories that are not listed in my papers and I don'T know where my board belongs to. Also, checking their files left my in complete mental darkness about the meaning of all those shortcuts, titles, and indices, and what I would need of that and what not (not to think of where it belongs). I would be crazy to mess around with that on my own without a guy here at my desk who'S knowing what he is doing.

    BTW, the link was bad for me, anyway I visited Tekram and searched from their mainpage, but don't ask me if I saw in that chaos of single files the one you mentioned!

    Skybird
  13. You don't have to update the BIOS for that driver, and I didn't saw any IDE fixes in the newer BIOS version.
    I have another links which enables you to install the Intel chipsets (you have a Intel 440BX chipset) drivers, it might help, but if you don't feel comfortabel then don't do it. Anyway this is the link:
    <A HREF="http://developer.intel.com/design/software/drivers/platform/inf/infinst_enu_pv22.htm" target="_new">http://developer.intel.com/design/software/drivers/platform/inf/infinst_enu_pv22.htm</A>.

    My case has so many fans that it hovers above the ground :eek: .
  14. I just did that, but it didn'T went smooth: for two times requester with no (or unvisible?) text appeared, I RETURNed, finally the win98SE disc was requested but at the same time the CD drive was no longer recognized, thus it was impossible to copy a file isapnp.vxd from the CD to HD, and it couldn'T been found on the HD (c/windows/options/cabs/isapnp.vxd). As the whole process was blocked, I clicked it away withoout copying. At the end I got warned that ending the process now wouldn'T finish the running installation, but no alternative there, I ended the install-window nevertheless. System went down and booted up. On the blackscreen before the windows logo appears for a very short ammount of time four messages appeared "invalid path, directory not empty or" and then something, "not found" I suggest. All the devices were then updated, the registration was updated, the CD was back on duty again, and no DOS-mode so far. Repeated booting will teach if the problem is gone or survived. Okay, but what about those missing files that are not accessible on the CD? And what about those error messages in the booting sequence? They are not joined by any more precise information, for example what they are targeted at.

    Stuff like this simply doesn'T happen with an abacus!
  15. If the problem isn't gone after reboot, you might want to check if there are any errors reported under control panel - system, if they ask to reinstall some drivers and you CD drives work again you can reinstall those with the Windows 98 CD.

    My case has so many fans that it hovers above the ground :eek: .
  16. Error message re-appears each time when rebooting. So far without any obvious effect. Maybe it will not appear before hours or days. If so, I will be back here! Right now it is night here in Germany and tomorrow I will be at work. No further answers by me for the next 24 hours, at least. Thank you very much, Svol, if I get into trouble again I hope I can count on you again!

    Skybird
Ask a new question

Read More

Hard Drives DOS DOS Mode Storage