Sign in with
Sign up | Sign in
Your question

New GTX 670 not performing as expected..

Last response: in Systems
Share
February 11, 2013 11:09:07 PM

Ok, so I just bought myself a nice new shiny GTX 670. ( http://www.newegg.com/Product/Product.aspx?Item=N82E168... ) it's not quite performing as I expected it would. It came with borderlands 2, so blahblah, played that for a while, downloaded some f2p games I used to lag on a little, they all worked great, 120+fps.. but then I got really deep into the story for bl2, more stuff started happening, etc. In really PhysX intensive situations it becomes really laggy. (saw 31fps once, which I used to think was really playable, but now even 40fps is kind of laggy to my eye) and that's just unacceptable. I turned the settings down A bit. AA down to 8 instead of 16, render distance down from ultra high to high, and turned like a few random settings from high to medium.. and it made literally 0 difference. just walking around at max settings I was getting 70-80fps, but as soon as anything happened, BAM 40-30 fps. really annoying. Now with the lower settings, its the same. even tried turning everything to minimum/off/720p, and I barely even saw 100fps idling.
Ok, borderlands 2 is pretty intensive, what with PhysX and what not running off the gpu (My cpu is an i7 3770k if anyone was wandering. also I'm not sure weather or not hyperthreading is enabled [pretty sure it was by default] if that makes any diff), SO. time to test some other more demanding games. I'm a cheapass and refuse to buy a game just to test my graphics card, so I downloaded planetside 2, expecting steady 60fps no matter what. Planetside 2 set to everything maxed, 6000 render, everything on as high as it can be, motion blur and all the other goodies, barely touches 50fps. when I'm 100% idle looking right at the sky where there's nothing to render I barely see the upper side of 60. i think, WTF? oh well, I'm sure it looks fine on lower settings (which it does) so i turned the render down to 4000, everything to medium, turned motion blur off (</3 R.I.P.) and made sure shadow detail was LOW. still barely saw the upper side of 60 fps. I've even seen it as low as 20-25 when there is a huge firefight, like 20v20 infantry and stuff. Did I get a bad card or was I just expecting too much? (Sorry I don't have any significant games like BF3 or Crysis 2 to test :c) I'm really worried xD neweggs 30 day return thing still isn't up, so if something IS wrong, I'd like to know.

EDIT: 1: sorry for wall of text
2: IDK how to look at gpu usage, but I know I overclocked it about 150-200 mhx in evga precision-x, didnt touch the voltage
3: cpu usage stays around 60% when in game, talking on skype, and browsing web, so I'm ok there. CPU is OC'd to 4.0 on stock cooler, NEVER hits 55C.
4: I kinda glanced at temps here and there and never say anything more than 50-60c even when I had like planetside 2, skype, firefox, evga precision-x, my cpu temp reader, and steam running all at once. so nothing seems to be wrong there. I'm most worried that turning the settings down didn't help/the random 25fps drops in ps2. (not down by 25, but down TO 20-25)
February 11, 2013 11:17:30 PM

This happened to me with my 560 Ti. I just played it for a bit ( like 2-3 weeks ) and it got better as I played. I think that's the problem. It may also be from wrong OC settings, but this is my advice.
m
0
l
February 11, 2013 11:23:13 PM

Ok... well I've had it for maybe a week and a half now. (I think? xD) I'll put it at stock clocks and see how that works. I'll also reboot and check if HT is on in bios.
m
0
l
Related resources
February 11, 2013 11:28:17 PM

try using msi afterburner, set the OSD so you can see gpu ram utilization, temps, etc.
m
0
l
February 11, 2013 11:29:57 PM

What drivers are you using?
m
0
l
February 11, 2013 11:30:56 PM

ok, so. I went into bios, hyperthreading was disabled, also went ahead and put my cpu back to 3.5GHZ, just to make sure. went into EVGA precision-x and spammed default... I'm gonna reboot and test in game.
m
0
l
February 11, 2013 11:31:28 PM

stickg1 said:
What drivers are you using?

The latest ones as of last week.
m
0
l
February 11, 2013 11:31:53 PM

Cons29 said:
try using msi afterburner, set the OSD so you can see gpu ram utilization, temps, etc.

English please, I'm good but I'm not that good.
m
0
l
February 11, 2013 11:46:18 PM

Meh, played borderlands 2 a bit, same story. :?
m
0
l
February 11, 2013 11:58:39 PM

Zed_Spooge said:
English please, I'm good but I'm not that good.


sorry, i mean, there is a setting there that sets the on-screen-display. so that you can see the stats like temp, gpu ram usage, etc
m
0
l
February 12, 2013 1:44:04 AM

Ok. thanks. MSI afterburner?
m
0
l
February 12, 2013 1:37:18 PM

Zed_Spooge said:
Meh, played borderlands 2 a bit, same story. :?


Yeah I had the exact same thing, as my card came pre-OCed to the max, it just took a bit to break into. If your warranty is almost done, and you still don't have it fixed, just trade it back in and see if another card works. I have no idea why, but NVIDIA cards that are OCed need time.
m
0
l
February 12, 2013 1:43:47 PM

Just turn the MSAA down.
m
0
l
February 14, 2013 12:47:32 PM

I refuse to turn settings down in games as simple as borderlands 2 and planetside 2 on an i7 and a 670. I should be maxing these out with no prob. and as I said turning down the settings doesn't really help all that much. (Plus borderlands 2 without physx is like a science fair without paper mache volcanoes.)'

Well anyways, I'm back, with more problems. Before I start any of this my monitor is: http://www.newegg.com/Product/Product.aspx?Item=N82E168... And my 670 is: http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Now, onto problems.
I'll copy paste the skype messages I sent to my friend about it, as they're kinda hard to describe and I'm not sure the technical jargan for any of this problems.:

it sends like
flickery lines across the screen with no color

Now as of earlier I THOUGHT it only did this in game but it's most visible when its against dark colors, and my wallpaper is really bright green, so I kinda figure I just didn't notice it. I just went into pain and made the entire screen back with grey around the edges and yeah, it does it then too, and even now looking down at the dark grey section on this website to select your region I can see it. its like flickering lines that move up and down the screen, like you see on old antenna TV. Hard to describe. also the previous fps
and as described in my message, they have no color. they're not like white, they just look.. off from the color behind them. these are the questions I have:
1: Is it my gpu or monitor? How do I test it? I have another monitor but its like 18' and not 1920x1080 (some weird res like 1650x) and I really don't wanna use that. I hate glossy. Also on this monitor all the whites look tinted slightly orange. I don't have any other GPU's. I MIGHT have access to my friends 7770, but, I dunno.
2: Could it possibly be because I couldn't find any wires that came with my GPU so I hooked my monitor from dual dvi video to vga? (white to blue)
3: HOW DO I TEST MY THEORIES XDD
4: Would it be reasonable to RMA it or simply return it for the 379.99 and buy a 7970? (I do really like PhysX in boderlands 2 and planned on buying the new alien game just for kicks, but its not a must have.)
5: Help? Really unhappy. I guess that's what I get for buying a 150$ monitor to guy with a 1250$ system. Also system specs are:

CPU: i7 3770k
GPU: EVGA GTX 670
MOBO: ASRock Z77 Extreme 4 LGA1155
RAM: 16GB G.Skill Sniper 1600mhz 9-9-9-24
HDD: WD Blue 750GB 7200RPM Drive (very happy with this btw, recording to it while playing from it with only like 5-7 fps drop, using fraps ofc)
PSU: Corsair CX 750M (also, my stuff is kinda jerry rigged, I couldn't find any power connectors dedicated to gpu or anything of the sort, so I just picked 2 6 pins and plugged them in on the psu wherever they fit xc)
CASE: not that it matters, but, Corsair C70 White. looks very nice.

Any suggestions? If I don't get some answers I'll make a new thread, just didn't want to be super spammy. TY very much.

EDIT: And regarding returning it, should I wait for like a new HD 8950 or a 770 and just hold out on IG 4000 on my cpu till then? I'm totally used to low settings and 20fps, so i should be fine. Would this be reasonable or? I DID feel kinda bad about buying a 670 right before the new cards came out.


m
0
l
February 14, 2013 12:56:50 PM

Zed_Spooge said:
I refuse to turn settings down in games as simple as borderlands 2 and planetside 2 on an i7 and a 670. I should be maxing these out with no prob. and as I said turning down the settings doesn't really help all that much. (Plus borderlands 2 without physx is like a science fair without paper mache volcanoes.)'

Well anyways, I'm back, with more problems. Before I start any of this my monitor is: http://www.newegg.com/Product/Product.aspx?Item=N82E168... And my 670 is: http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Now, onto problems.
I'll copy paste the skype messages I sent to my friend about it, as they're kinda hard to describe and I'm not sure the technical jargan for any of this problems.:

it sends like
flickery lines across the screen with no color

Now as of earlier I THOUGHT it only did this in game but it's most visible when its against dark colors, and my wallpaper is really bright green, so I kinda figure I just didn't notice it. I just went into pain and made the entire screen back with grey around the edges and yeah, it does it then too, and even now looking down at the dark grey section on this website to select your region I can see it. its like flickering lines that move up and down the screen, like you see on old antenna TV. Hard to describe. also the previous fps
and as described in my message, they have no color. they're not like white, they just look.. off from the color behind them. these are the questions I have:
1: Is it my gpu or monitor? How do I test it? I have another monitor but its like 18' and not 1920x1080 (some weird res like 1650x) and I really don't wanna use that. I hate glossy. Also on this monitor all the whites look tinted slightly orange. I don't have any other GPU's. I MIGHT have access to my friends 7770, but, I dunno.
2: Could it possibly be because I couldn't find any wires that came with my GPU so I hooked my monitor from dual dvi video to vga? (white to blue)
3: HOW DO I TEST MY THEORIES XDD
4: Would it be reasonable to RMA it or simply return it for the 379.99 and buy a 7970? (I do really like PhysX in boderlands 2 and planned on buying the new alien game just for kicks, but its not a must have.)
5: Help? Really unhappy. I guess that's what I get for buying a 150$ monitor to guy with a 1250$ system. Also system specs are:

CPU: i7 3770k
GPU: EVGA GTX 670
MOBO: ASRock Z77 Extreme 4 LGA1155
RAM: 16GB G.Skill Sniper 1600mhz 9-9-9-24
HDD: WD Blue 750GB 7200RPM Drive (very happy with this btw, recording to it while playing from it with only like 5-7 fps drop, using fraps ofc)
PSU: Corsair CX 750M (also, my stuff is kinda jerry rigged, I couldn't find any power connectors dedicated to gpu or anything of the sort, so I just picked 2 6 pins and plugged them in on the psu wherever they fit xc)
CASE: not that it matters, but, Corsair C70 White. looks very nice.

Any suggestions? If I don't get some answers I'll make a new thread, just didn't want to be super spammy. TY very much.

EDIT: And regarding returning it, should I wait for like a new HD 8950 or a 770 and just hold out on IG 4000 on my cpu till then? I'm totally used to low settings and 20fps, so i should be fine. Would this be reasonable or? I DID feel kinda bad about buying a 670 right before the new cards came out.


You don't need the newest things to play the newest games. I wouldn't recommend getting the newer cards and CPUs when they come out. Just because they are new, doesn't mean they are something you should get. They will be expensive and I don't see the need of upgrading. Once again, you should try and get a refund or get a new one just to see if it was maybe damage that caused this problem. Your card and CPU could max out Crysis 3, and that's the biggest game right now, graphics wise. See if you can get a return.
m
0
l
February 14, 2013 12:59:30 PM

recommended specs for crysis 3 at max is 3770k and a 690 xD I'll probs play on medium.

THE MAIN QUESTION I NEED ANSWERED Is it my monitor or my 670? :p  the flickering is more annoying, I can stand playing on low settings. (the way its going I don't see my system playing bf3 and even pulling 40fps, which is the main reason I bought this damned thing. BTW playable mark for fps IMO is 45. so.)

EDIT: I do plan on buying an 800 series card if/when they come out, because if things upgrade at the rate they upgraded from 570 to 670 (~50%) then an 880/2 generations down the road should be 100% faster than my card, if my system will even be compatible. maybe even getting another 670 when they're like 250$. :p 
DOUBLE EDIT:
those recommended specs were for the very poorly optimized alpha, though
TRIPLE EDIT YEAA: Also I'm considering returning it and getting a 680, just so I can record at max settings, and for a little fps boost. VERY dissapointed, really impressed with my friends little 7770 though.
m
0
l
February 14, 2013 1:03:15 PM

Zed_Spooge said:
recommended specs for crysis 3 at max is 3770k and a 690 xD I'll probs play on medium.

THE MAIN QUESTION I NEED ANSWERED Is it my monitor or my 670? :p  the flickering is more annoying, I can stand playing on low settings. (the way its going I don't see my system playing bf3 and even pulling 40fps, which is the main reason I bought this damned thing. BTW playable mark for fps IMO is 45. so.)


http://www.joystiq.com/2012/12/03/crysis-3-system-requi...

You'll be playing near max. If you OC you can get max. How many Hz is your monitor? Can you tell me the exact name and brand?
m
0
l
February 14, 2013 1:11:00 PM

Wait, are you plugging in the 670 using VGA?
m
0
l
February 14, 2013 1:12:35 PM

From Dual DVI on the card to VGA on the monitor. I know I suck but it's the only cable that would fit that came with any of it. :?
m
0
l
February 14, 2013 1:13:46 PM

Zed_Spooge said:
From Dual DVI on the card to VGA on the monitor. I know I suck but it's the only cable that would fit that came with any of it. :?


So you didn't use HDMI? Why?

Get an HDMI cable. I've seen people having HUGE improvements using it instead of that VGA crap.
m
0
l
February 14, 2013 1:16:04 PM

SHORYUKEN said:
So you didn't use HDMI? Why?

Get an HDMI cable. I've seen people having HUGE improvements using it instead of that VGA crap.

Well gimme a minute or two to fish around in my box of crap that came with my order to see if I have any other cables. I'll post here when I'm reconnecting or rebooting or anything so I'm still here checking and responding. KEEP THE HELP COMING ;-;
m
0
l
February 14, 2013 1:18:36 PM

Zed_Spooge said:
Well gimme a minute or two to fish around in my box of crap that came with my order to see if I have any other cables. I'll post here when I'm reconnecting or rebooting or anything so I'm still here checking and responding. KEEP THE HELP COMING ;-;


You should ALWAYS have an HDMI cable. You never know. I have like 4.
m
0
l
February 14, 2013 1:20:08 PM

Ok yeah I don't have an HDMI cable. I'll go buy one later today. Is that all I need? HDMI to HDMI cable? I'mma brb, turn off my comp so I can check behind it to see what options I have
m
0
l
February 14, 2013 1:22:21 PM

Zed_Spooge said:
Ok yeah I don't have an HDMI cable. I'll go buy one later today. Is that all I need? HDMI to HDMI cable? I'mma brb, turn off my comp so I can check behind it to see what options I have


Yeah since you have a 670, which has a built in 1 HDMI, and your monitor has an HDMI, you just need a double ended cable. I recommend getting the " middle " expensive one. Don't get the cheapest one imo. The cheaper ones are the poop ones. Key words to look for are " high speed ", " gold plated " and 1080p.
m
0
l
February 14, 2013 1:35:02 PM

Ok, so, here's how I have it hooked up atm. I have a VGA to VGA hooked to a VGA To Dual DVI, VGA hooked to my monitor, and Dual DVI hooked to my 670. I also have a --- to ---- cable I have 0 Clue what it is. Its chaped like a normal DVI hook except for pins there is: 2 seperate groups of 9 pins and 1 horizontal, longer pin on the side. It's white if that makes a difference. SHORY you mind linking me to a decent one? :?
m
0
l
February 14, 2013 1:41:09 PM

Is this decent? Most of them were like 4$ so I assume so. http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Also looking for a really cheap mousepad/headset (Like, REALLY cheap. <10$ cheap xD) if anyone has suggestions. I just need a mic to talk to my friends and a mousepad other than my current one. Using one of the old ones that are like blue and has water drops on it xDD

And oh sweet god that's three cables.... I suck. Suggestions? xD
m
0
l
February 14, 2013 1:43:39 PM

Zed_Spooge said:
Ok, so, here's how I have it hooked up atm. I have a VGA to VGA hooked to a VGA To Dual DVI, VGA hooked to my monitor, and Dual DVI hooked to my 670. I also have a --- to ---- cable I have 0 Clue what it is. Its chaped like a normal DVI hook except for pins there is: 2 seperate groups of 9 pins and 1 horizontal, longer pin on the side. It's white if that makes a difference. SHORY you mind linking me to a decent one? :?


I personally use a $100 one xD. I can't really recommend one, just look for a ~$10 one and you should be fine. There are literally thousands out there. Also, I have no idea about the " unnamed " port. Is there any way for you to get a picture? If you look at your exact model on amazon or Google or something, maybe I can look at the back. Also, I suggest getting a VGA to HDMI just in case. They're really cheap. Like ~$5 cheap.
m
0
l
February 14, 2013 1:46:30 PM

Yeah my camera is charging atm I'll have a pic up in 5 or ten minutes. I was gonna post pics just now but camera was dead. Want pics of system internals? I can link them if you want, I did a pretty sh*tty job. took me like 10 hours, didn't look at the manual to anything once. But hey it works... sorta.
m
0
l
February 14, 2013 1:47:46 PM

Zed_Spooge said:
Is this decent? Most of them were like 4$ so I assume so. http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Also looking for a really cheap mousepad/headset (Like, REALLY cheap. <10$ cheap xD) if anyone has suggestions. I just need a mic to talk to my friends and a mousepad other than my current one. Using one of the old ones that are like blue and has water drops on it xDD

And oh sweet god that's three cables.... I suck. Suggestions? xD


Yeah I think my HD PVR 2 has those cables. They are quite nice. <$10 cheap is a near impossibility. Even mouse pads aren't that cheap, unless you make it yourself. I just use some crappy mouse pad I found in my house and it has been working for like 3 years now. But something you should avoid when buying a headset, is Turtle Beach. If you tend to get angry or you are " strong " (as in you have enough strength to lightly toss a headset against a couch) then Turtle Beach is horrible. But it is cheap. But horrible. They break EASILY. I had 2 Turtle Beaches, each lasting for <1 year because I throw them against my couch and BOOM they break. I suggest getting a steel/metallic core headset if you tend to throw your headset. If not, Turtle Beach is ok.
m
0
l
February 14, 2013 1:49:28 PM

Zed_Spooge said:
Yeah my camera is charging atm I'll have a pic up in 5 or ten minutes. I was gonna post pics just now but camera was dead. Want pics of system internals? I can link them if you want, I did a pretty sh*tty job. took me like 10 hours, didn't look at the manual to anything once. But hey it works... sorta.


Give me all the pics you want. lol not even once? That must of been difficult telling what cables connect to what and what screws go were on the MoBo.
m
0
l
February 14, 2013 1:56:42 PM

Well I had watched tut videos in the past, of course. I'm just pr0 like that; Here are some pics of the comp:
https://sphotos-a.xx.fbcdn.net/hphotos-ash3/p206x206/53...

https://sphotos-b.xx.fbcdn.net/hphotos-prn1/148378_1975...

https://sphotos-b.xx.fbcdn.net/hphotos-prn1/46742_19750...

https://sphotos-b.xx.fbcdn.net/hphotos-ash4/419668_1975...

https://sphotos-a.xx.fbcdn.net/hphotos-ash3/72370_19750...

https://sphotos-a.xx.fbcdn.net/hphotos-ash4/424531_1947... - I have windows now this was before I found a USB stick to install it on. Laptop in the corner is what I used to use, my mouse is the Mionix NAOS 3200.

Ok. I got pics of the mystery cable, Ill post them in a sec.
m
0
l
February 14, 2013 2:02:10 PM

Wait a minute. I only looked at the first picture, but are you trying to OC using the default heatsink?! Why didn't you just get a cooler? The poor heatsink is sitting there sh*tting brinks! I would recommend getting a nice CPU cooler, such as a Noctua or a Hyper EVO.
m
0
l
February 14, 2013 2:04:39 PM

Hahaha! I overclocked it to 4.2 with stock heatsync and never hit 55C XDD I downclocked it to 4.0 just in case though :) 

EDIT: PROBABLY because overclocking in MHZ hardly adds any heat. Upping voltage is what heats things up, and I didn't have to add any voltage at all to get it stable at 4.2 c:
m
0
l
February 14, 2013 2:05:28 PM

Zed_Spooge said:
Hahaha! I overclocked it to 4.2 with stock heatsync and never hit 55C XDD I downclocked it to 4.0 just in case though :) 


Still. So did you get the picture?
m
0
l
February 14, 2013 2:17:56 PM

I just need the cheapest mic that my friends can understand what I'm sayin, lol. I'll buy a decent ~50$ headset with an OK mic later. I'm not that curious cx I'll update this if/when I get an HDMI cable. TBH I kinda hope my 670's fugged up so I have an excuse to return it and buy a 680 xS
m
0
l
February 14, 2013 2:19:41 PM

Zed_Spooge said:
I just need the cheapest mic that my friends can understand what I'm sayin, lol. I'll buy a decent ~50$ headset with an OK mic later. I'm not that curious cx I'll update this if/when I get an HDMI cable. TBH I kinda hope my 670's fugged up so I have an excuse to return it and buy a 680 xS


You could manually f*ck it up. Overclock it so that it breaks, etc. But yeah, look at all the different cables, and try to test them all out if the store has like a 30 day return policy.
m
0
l
February 14, 2013 2:22:13 PM

Ok thanks :)  Happy Valentines day btw. and lol @ you telling me to manually mess it up so I can return it.. hahaha... haha.. ha. xD
m
0
l
February 14, 2013 2:24:59 PM

Zed_Spooge said:
Ok thanks :)  Happy Valentines day btw. and lol @ you telling me to manually mess it up so I can return it.. hahaha... haha.. ha. xD


Happy Valentines to you too xD. Yeah I thought about screwing up my 560 Ti because it didn't work the way I wanted at first but now it works a lot better.
m
0
l
February 14, 2013 2:38:12 PM

Hows a 560ti do in bf3? just curious
m
0
l
February 14, 2013 2:42:51 PM

Zed_Spooge said:
Hows a 560ti do in bf3? just curious


Don't have BF3 but looking at benchmarks at a non-OC card with i5-2500k:

60+ frames on low.
60+ frames on medium.
50+ frames on high.
30-50 frames on ultra.

With my OC card + a 3570k, you should get 50+ frames on Ultra.
m
0
l
February 14, 2013 2:47:52 PM

wow... I guess my 670 will do well in bf3 x3 with any luck of course. by the way I noticed on my 670 theres another connector thats not power on the top. what's that for? (I left the rubber thing that protects it on, but it looks like gold teeth, like the bit that plugs into the mobo only smaller)
m
0
l
February 14, 2013 2:50:25 PM

Better cooling I believe. I'm not too sure. I just took off everything, as if you leave the plastic on, it can melt and damage your parts.
m
0
l
February 14, 2013 2:56:12 PM

Yeah I know what you're talking about. I don't know xD. Never used it.
m
0
l
February 14, 2013 2:58:07 PM

How would it relate to cooling? maybe like something for a fan/pump controller?
m
0
l
!