Sign in with
Sign up | Sign in
Your question

Help with installing a graphics card on i3

Last response: in Graphics & Displays
Share
December 27, 2012 7:45:05 PM

hi all,

i shall explain the situation.........

i have a hp pavillion tower running a i3 3.5ghz with the rubbish intel HD 2000 integrated graphics.

ive just bought a GT630 (not the best i know) and ive installed it in the PCIe slot and started the pc up.

as per the installation instructions ive swaped my monitor cable from the integrated port to the new gt630 port.

The computer seems to boot up fine however all i get is a black screen and a white mouse pointer. This is before the log in page. Also when booting there is no hp logo anymore and no way to get to the bios etc,,,,,Its just black.

I swapped the cable back to the integrated monitor port but now it says no signal.

The only way i can get my screen back is to physically unplug the graphics card from the PCIe port and reboot putting the cable back into my integrated port.

I know its not the card as its brand new, and ive also tried another card in the PCIe slot and it does exactly the same thing...........

please help.

Liam

December 27, 2012 7:53:18 PM

just to add, im also running windows 8
a b U Graphics card
a b α HP
December 27, 2012 9:17:38 PM

Sounds like the priority for the graphics card in bios is not set right.
a b U Graphics card
a b α HP
December 27, 2012 10:05:56 PM

I agree, using the hd200 integrated graphics, enter the bios and select "Initialize PCIe" as the first graphics card or sometimes its called PEG. Then save and powerdown, unplug, and then install the gt630
!