Sign in with
Sign up | Sign in
Your question

Router/server

Last response: in Linux/Free BSD
Share
February 5, 2002 1:49:45 AM

Okay, my dad just bought himself a new computer, so I get to play with the old P200 MMX, 2.1 gig drive, 80 megs EDO... and I'm gonna put linux on it and set it up as a router for our home LAN that I'm also going to build.

Can anyone recommend any good sites for setting up apache, samba, routers, and email and ftp serving programs. I don't need anything too heavy duty here, just serving up pics for the family and stuff.

Lyrics. Wasted time between solos.

More about : router server

February 5, 2002 8:41:22 AM

I've found the HOWTOs and mini-HOWTOs pretty good for that stuff. There's a couple dedicated to Home LANs. Just take it piece by piece. Start with the router (probably dns, dhcpd, squid, firewalling, ipchains/iptables etc) first, then apache, samba, imap, ftp, etc. Expect a few headaches the first time though, as you get intimate with the configuration files.

If it's on a full time connection, you should probably look at the security side of things too. There's some good online guides available from linuxdoc.org.

80 megs EDO! Woot! :-)
February 5, 2002 11:14:37 PM

I would seriously recommend webmin. Makes it easy to set stuff up.

BTW, doing squid, calamaris (monitor squid) and iptables are pretty hard...

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
Related resources
February 6, 2002 5:28:43 AM

Okay, I got the thing set up. I'm still having problems though. Here's what I've got:


Router machine: running linux mandrake. 2 NICs installed.

I've set eth0 to be connected to the cable modem and is obtaining it's IP via DHCP. No problems here as I can access the internet with this machine.

eth1 is set to have an ip address of 192.168.0.1 and is the default gateway for my network. I've run netconf and made sure both NICs are enabled, and that this one has this address.

I've also set up the DNS servers to the addresses provided by my ISP.

I've also added the lines:

echo "1" /proc/sys/net/ipv4/ip_forward
ipfwadm -F -p deny
ipfwadm -F -a m -S192.168.0.2/24 -D0.0.0.0/0

to /etc/rc.d/rc.local


Now, my client box is running XP pro, and I've edited my network settings to match that of the linux box. I can ping the linux box from the XP box and vice versa (400 microsecond pings w00t), but I can't access the 'net from my XP box.

Lyrics. Wasted time between solos.
February 6, 2002 6:42:02 AM

It sounds like you have the right settings (ip, gateway etc) on your XP Box. Does ipconfig agree? I guess you're using DHCP from dhcpd running on the Linux box, or static IP settins on XP.

What does route -n on the linux box say?

ipfwadm is ok, but maybe you should be using ipchains instead...

Edit: Sub 300ms pings here. DLink and Netgear NICs ;-)



<P ID="edit"><FONT SIZE=-1><EM>Edited by poorboy on 02/06/02 04:04 AM.</EM></FONT></P>
February 6, 2002 7:47:30 AM

Hmm, well I ran ipconfig on my XP box before I manually assigned it an address, and it came up with 169.254.236.0, which is not any IP address I've seen for this computer ever before. I have no idea where it came from. I didn't run it after manually assinging an address though. I'd do it now, but I shut down the linux box, and the stupid thing takes forever to boot. Oh, and it's bedtime, so I'll do it in the morning.

Thanks for the help.

Lyrics. Wasted time between solos.
February 6, 2002 7:55:21 AM

If Win2K/XP etc is set to automatically determine it's IP address, it'll first look for a BootPS or DHCP server, if that doesn't work it'll then try to find an unused network range to set itself up in. The 192.168.x.x net was used, so it went for 169.254.x.x ...
February 6, 2002 11:56:54 AM

until recently i hat redhat on a p60 for a firewall/router, had a few probs with forwarding, anyway, I decided to try <A HREF="http://www.freesco.org" target="_new">freesco</A> its GOOD, runs from a floppy, VERY easy to setup, and you can admin it from anotherpc on the lan (also from external if you enabled that option), I set mine up in literally 10 minutes. Maybe have a try, if you dont like it/doesnt work for you all you have used is 1 floppy and some time!


If they squeeze olives to get olive oil, how do they get baby oil?
February 6, 2002 2:21:48 PM

Yeah, I know that... I then set the IP info manually in XP, but it didn't work either... oh well.

Gotta go to class now, I'll work on it some more when I get back home.

Lyrics. Wasted time between solos.
February 6, 2002 7:02:07 PM

w00t!

<adam sandler voice>I AM THE SMARTEST MAN ALIVE!</adam sandler voice>

Finally got it figured out. I didn't like ipfwadm, so I tried the 2.4.x kernel supported iptables. Found a good site (thanks google!) that gave me a script to add to my rc.local that fixed everything. I rule.

Thanks for the help everyone.

Lyrics. Wasted time between solos.
!