Sign in with
Sign up | Sign in
Your question

New build won't boot :(

Last response: in Systems
Share
February 12, 2013 10:58:13 PM

Hi guys,

This morning I received my new gfx card and psu, plan was just to install them and use them until the end of the month when I get my i5, mobo/ram etc.

Problem started when I noticed the casing of my XFX 7870 was too big for the mobo because the sata ports were in the way.

I had a brand new ASRock N68c-s UCC mobo sitting in the cupboard for a year, so I decide just to move everything over to that.

Hours later and everything powers up, all the fans spin, but it doesn't boot. There's no post beeps, nothing happens on monitor, the led light on the Ethernet port isn't lit up.

After going back to the basics and just having 1 stick of ram, CPU, hdd connected to the mobo I still get nothing. Power... But no boot. Even when I remove all ram I don't get the successive beeps from the system. Also tried powering the basics with my old psu but get the same results. Does this indicate a CPU problem, mobo, or maybe a combination of the 2 together?

I'm at a loss, I've been doing this all day. Current build is...
Amd Athlon II x2, ASRock N68C-S UCC, XFX 7870 2gb, XFX pro 650w and 4gb (2x2) of HyperX blue ddr2.

Please help me :( 

More about : build boot

February 17, 2013 1:46:51 AM

How are you connecting the monitor to the board? VGA? Or are you using the hd 7870? Is your monitor set to receive the correct output from the card? VGA? HDMI? DVI?
!