Sign in with
Sign up | Sign in
Your question

Hdmi HDTV washed out colour

Last response: in Graphics & Displays
Share
December 28, 2012 2:33:23 PM

Hey,

For christmas I got a samsung 5 series Full hd internet tv etc and went to connect it to my PC however when i connected it the colours appeared really washed out in comparison to my monitors. Even my previous 720p TV looked better. The Tv is fine when watching TV and on the HD channels looks great and a million miles away from the PC version. Is there a setting which will change this somewhere?

Thanks
December 28, 2012 2:55:36 PM

it almost sounds like there is a mismatch in the video signal, the tv is expecting a full range rgb (0-255) and the video card is only giving out limited range (16-235), solving the issue depends on the rest of the hardware config in use. I assume you are using hdmi?


or it could be something completely different...
December 28, 2012 3:06:12 PM

I'm using HDMI yes, with an ati radeon 6950.
Related resources
December 28, 2012 3:20:25 PM

amd drivers should autodetect the rgb mode and set it up properly... it might be something different.
You could take a look at this test image:
http://www.lagom.nl/lcd-test/contrast.php
if the rgb mode is wrong the rightmost bars should blend together (in most colours) and also the darkest shades could be completely black. Adjusting contrast/brightness settings should not fix it, the middle tones will change but not the extremes.
December 28, 2012 3:26:59 PM

Kari said:
amd drivers should autodetect the rgb mode and set it up properly... it might be something different.
You could take a look at this test image:
http://www.lagom.nl/lcd-test/contrast.php
if the rgb mode is wrong the rightmost bars should blend together (in most colours) and also the darkest shades could be completely black. Adjusting contrast/brightness settings should not fix it, the middle tones will change but not the extremes.


Yeah, it must be that. I just did it and the monitors didn't blend them however on the TV about 5-6 were blended. How would i go about fixing that then?
December 28, 2012 3:59:29 PM

there might be a setting in the TV menus named something like rgb range or black level etc for the hdmi input.. so you could change it to the same limited version as the card. Ideally you'd want to switch the card into full range thou. not sure how you'd do that... as i said the drivers should autodetect it and the setting isn't shown in the control center
December 28, 2012 4:01:50 PM

Kari said:
there might be a setting in the TV menus named something like rgb range or black level etc for the hdmi input.. so you could change it to the same limited version as the card. Ideally you'd want to switch the card into full range thou. not sure how you'd do that... as i said the drivers should autodetect it and the setting isn't shown in the control center


Ok, cheers for the help. I will look into that!
December 28, 2012 4:08:41 PM

btw what driver version are you using? update might help...
December 28, 2012 4:20:21 PM

Kari said:
btw what driver version are you using? update might help...


Not sure, but it says it last updated today so I guess the latest drivers.
December 28, 2012 4:52:34 PM

Ok, so i can't find any settings for the colour that change it, however I have noticed the screen seems zoomed in a little? Would that change the quality at all? how would i stop that?
December 28, 2012 5:09:02 PM

Lfluxx said:
Not sure, but it says it last updated today so I guess the latest drivers.

check it in the CCC under information/software it should say the catalyst version. latest whql driver is 12.10 I believe, thou the 12.11 betas have been quite nice

Lfluxx said:
Ok, so i can't find any settings for the colour that change it, however I have noticed the screen seems zoomed in a little? Would that change the quality at all? how would i stop that?

it seems some samsungs call it 'colour space', might not be present on every model I suppose. Zooming shouldnt affect colours afaik, but the over/underscan setting in CCC under 'My digital flatpanels'/'scaling' should help to make it fit properly.
December 28, 2012 5:34:16 PM

Kari said:
check it in the CCC under information/software it should say the catalyst version. latest whql driver is 12.10 I believe, thou the 12.11 betas have been quite nice


it seems some samsungs call it 'colour space', might not be present on every model I suppose. Zooming shouldnt affect colours afaik, but the over/underscan setting in CCC under 'My digital flatpanels'/'scaling' should help to make it fit properly.


Found the colourspace option, native ( which it was on ) improves it and auto makes it worse. I tried change the scaling however it is stuck on full overscan and i can't change it. :l
December 28, 2012 5:43:02 PM

Lfluxx said:
Found the colourspace option, native ( which it was on ) improves it and auto makes it worse. I tried change the scaling however it is stuck on full overscan and i can't change it. :l

then it is probably something else that is messing your colours. and that is weird...
February 15, 2013 8:55:11 PM

Sorry to revive this thread a bit but the problem is still ongoing. However I think I may have a solution? The TV is stuck on full overscan and the picture is larger than the actual screen, however I can't change the damn overscan. After googling/reading some sites I found this solution however i'm not quite sure what to add in where? ( I know how to add the registry it's just knowing what goes where if that makes sense? )

Anyways here is the "advice"

I found a fix for the overscan issue
Go to the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\video{####....}\0000
Create a new DWORD:
"DigitalHDTVDefaultUnderscan" = dword 0x0000
Note: there might be several {####....} , should be the one with most of the ATI settings.
Source:http://forum.beyond3d.com/showthread.php?t=62100

Any help?
March 8, 2013 8:57:48 AM

HTPC colours washed out unsharp for AMD APU Nvidia Hdmi 1.3 1.4 1.4a output Mini ITX or whatever

For colours to be accurate you have to set
1. Hdmi input of tv label to pc
2. Choose tv colour spacing bt. 709
3. set gamma on tv at maximum ,at least 2.35 for THX certification
4. Use YCbCr 4:4:4 on hdmi out
5. Calibrate all

Also madAVR settings has advanced calibration feature for TV's but dont touch colour profiles use BT 709
June 5, 2014 7:48:30 PM

Hi guys,

Sorry to resurrect the topic I'm having the same issue. I'm using HDMI cable from my PC to my TV and VGA cable on my monitor to my PC. The colors aren't the same on the TV, kind of washed out. I tried to do some manual Color correction myself but it's not even close.
!