Sign in with
Sign up | Sign in
Your question
Closed

Nvidia 310.70 drivers keep breaking forcing me to reinstall, fix?

Last response: in Graphics & Displays
Share
December 28, 2012 6:02:58 PM

Hi, a few days ago I upgraded my graphics card to a Nvidia GTX 550 ti. I put in the graphics card myself, along with a new power supply and booted up, installed the Nvidia drivers off a disc and restarted my PC. I then updated them to 310.70 by downloading them from the official website. It worked great for a while then after 6-8 hours I started to get stuttering gameplay in games like Xcom: Enemy Unknown and Arma 2. My framerate kept on fluctuating between 60-10 fps, usually if I looked somewhere new in the game. I tried reinstalling the drivers after a while, and it worked great again. I rebooted my PC the next morning and was met with the same problem, so I set out to look for a solution. Nothing I have found seems to work, these are things I've tried:

1. Reinstalling drivers
2. Using driver sweeper to clear all Nvidia drivers and reinstalled drivers
3. Booting in safe mode and using driver sweeper to clear all Nvidia drivers and reinstalling drivers (all in safe mode)
4. Getting a fresh download of the drivers.

This is getting quite annoying having to do this 2-3 times a day, so if anyone has a fix I would greatly appreciate it.

PC specs:

OS: Windows 7 64 bit
Processor: Intel i3-2120 3.3Ghz
Gfx Card: Nvidia GTX 550 ti (upgraded from Intel HD Graphics)
PSU: 600W corsair (upgraded from 240w)
RAM: 8Gb
!