Closed Solved

Urgent problem with GPU

Upon installing my GPU (Sapphire Radeon HD 7950) I made an idiotic mistake and forgot to plug in the power connectors. Well now I have and the card doesn't seem to work. Can someone please tell me that I didn't just break the card? Is there any kind of fix to this? Did I just screw myself over majorly?
7 answers Last reply Best Answer
More about urgent problem
  1. Take the card out and reseat it and then plug the power connectors and try it
  2. Tried it. No result. The fans aren't spinning.
  3. Actually its possible that its a Motherboard issue because I've had issues with the board. I'm getting it looked at soon. I better just wait until than.
  4. Best answer
    Yea your computer normally just wouldn't start without the power connection to the card or it would shut itself off. I think you are just fine you forgot to but its okay. if its the motherboard its the motherboard but I'm almost certain its not your card and even if it is you can return it saying its DOA.
  5. Best answer selected by xTactical Llama.
  6. bigshootr8 said:
    Yea your computer normally just wouldn't start without the power connection to the card or it would shut itself off. I think you are just fine you forgot to but its okay. if its the motherboard its the motherboard but I'm almost certain its not your card and even if it is you can return it saying its DOA.


    Okay thanks. I don't think I can explain how worried I was.
  7. We all have moments where we get stressed out and were trying to have things work right this minute and right this second I can attest to feeling that way at times. You will get it sorted out man :) I wouldn't worry about the card and you still have options where your card is concerned and you said you are having your mobo looked at so things can only look up.
Ask a new question

Read More

Graphics Cards GPUs Sapphire Radeon Graphics