Solved

COMPUTER BUILD HELP

Hi, I am upgrading some parts in my computer and have ran into a problem. After putting all the parts in and connecting the cables my computer won't boot up. When trying to start in up my computer case's LEDs flash and nothing happens. I would be grateful for any help.

SPECIFICATIONS:
BIOSTAR TZ77B LGA 1155 Intel Z77 - Motherboard (NEW PART)
RAIDMAX RX-500S 500W ATX12V - Power Supply
MSI RADEON HD 6850 - Graphics Card (NEW PART)
Intel Core i5-3570K - CPU (NEW PART)
WESTERN DIGITAL GREEN 1.5TB - Hard Drive
(2) Crucial Ballistix Sport 8GB 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model - RAM (NEW PART)
RAIDMAX SMILODON Extreme Black - Case
5 answers Last reply Best Answer
More about computer build help
  1. The first thing to do with that computer is to get a new power supply - Raidmax is one of the worst brands out there for power supplies.
  2. Yeah I plan on getting a new one as soon as I get some more money, but do you think the power supply is causing this or is it because I did something wrong?
  3. Best answer
    According to http://forum-en.msi.com/faq/article/power-requirements-for-graphics-cards a 6850 requires 25 amps on the +12V rail, but according to the Newegg specs, your psu can only deliver 22 amps (28 according to the sticker in the images), but I wouldn't be surprised if the effective limit is actually lower. I hope you haven't already fried your other components.
  4. Best answer selected by mike8008.
  5. Alright thank you I will get a new power supply.
Ask a new question

Read More

New Build Computers Systems