Need help urgent

I just built my first custom build and the desktop let out smoke. I saw that the cpu power connector wasn't plugged in. The cpu fan won't work but the case fans connected to the motherboard works. The system boots up too but the cpu fan isn't working. Help please
10 answers Last reply
More about need urgent
  1. Smoke? Did you see from where?

    I advise checking that out and replacing whatever did it (most likely the PSU).
    Also don't turn on the machine without some form of cooling on the CPU, make sure its installed correctly, if its just outright broke, go out and buy a 212 EVO to replace it.
  2. The psu powers the other pieces though. Like the cd drive and sata drive. I don't think it's the psu. I saw the smoke from the top of the case. The system shut down after smoking but I think that was because of the cpu power not plugged in
  3. Sounds like your CPU overheated and fried, so was there no cpu fan running?
  4. how long was it running without it?
  5. Okay guys looks like the fan burned the plastic on the cpu. I'm guessing the fan is bad. Any checks to make sure the cpu is good?
  6. was it a stock fan? if so return them together, saves you the hassle.
  7. Yeah stock Intel fan. I got a replacement coming for it. Going to return the fan and cpu
  8. Good luck man
  9. technub said:
    Okay guys looks like the fan burned the plastic on the cpu. I'm guessing the fan is bad. Any checks to make sure the cpu is good?

    CPUs almost never go bad - don't worry!
Ask a new question

Read More

Homebuilt Desktops CPUs Build Systems