Sign in with
Sign up | Sign in
Your question

Need help urgent

Last response: in Systems
Share
February 16, 2013 1:36:53 AM

I just built my first custom build and the desktop let out smoke. I saw that the cpu power connector wasn't plugged in. The cpu fan won't work but the case fans connected to the motherboard works. The system boots up too but the cpu fan isn't working. Help please

More about : urgent

a c 106 B Homebuilt system
a c 115 à CPUs
February 16, 2013 1:43:33 AM

Smoke? Did you see from where?

I advise checking that out and replacing whatever did it (most likely the PSU).
Also don't turn on the machine without some form of cooling on the CPU, make sure its installed correctly, if its just outright broke, go out and buy a 212 EVO to replace it.
m
0
l
February 16, 2013 1:53:35 AM

The psu powers the other pieces though. Like the cd drive and sata drive. I don't think it's the psu. I saw the smoke from the top of the case. The system shut down after smoking but I think that was because of the cpu power not plugged in
m
0
l
Related resources
February 16, 2013 1:57:48 AM

Sounds like your CPU overheated and fried, so was there no cpu fan running?
m
0
l
February 16, 2013 1:58:42 AM

how long was it running without it?
m
0
l
February 16, 2013 2:29:41 AM

Okay guys looks like the fan burned the plastic on the cpu. I'm guessing the fan is bad. Any checks to make sure the cpu is good?
m
0
l
February 16, 2013 2:35:30 AM

was it a stock fan? if so return them together, saves you the hassle.
m
0
l
February 16, 2013 3:08:42 AM

Yeah stock Intel fan. I got a replacement coming for it. Going to return the fan and cpu
m
0
l
February 16, 2013 4:00:45 AM

Good luck man
m
0
l
a b B Homebuilt system
a c 102 à CPUs
February 16, 2013 1:48:30 PM

technub said:
Okay guys looks like the fan burned the plastic on the cpu. I'm guessing the fan is bad. Any checks to make sure the cpu is good?

CPUs almost never go bad - don't worry!
m
0
l
!