Sign in with
Sign up | Sign in
Your question

Sapphire 7850 2gb help

Last response: in Graphics & Displays
Share
December 30, 2012 6:50:45 PM

For xmas i got a sapphire 7850 2gb oc edition card, 8gb of ram and a new psu to run it all. After installing all the new part my computer has really suffered, i get really bad mouse lag whenever i try and do things on the desk top or watch vidoes on the internet. After taking each of the new parts out individually the problem seems to be the card, i have my old hd 6450 and everything is running back to normal. I updated all my drivers for motherboard and the card, even reinstalled them again to make sure. starting to get a bit annoyed now because they were all presents and i dont want them to be money wasted. the specs of my pc are

CPU: AMD Phenom II X4 Black Edition 970, 3500 MHz (17.5 x 200)
PSU: OCZ ZS550W-UK ATX PSU - 550 W
Motherboard: Asus M5A87 (3 PCI, 2 PCI-E x1, 1 PCI-E x16, 4 DDR3 DIMM, Audio, Gigabit LAN)
GPU: Sapphire Radeon 7850 2gb OC edition
System Memory: 12gb (DDR3-1333 DDR3 SDRAM) from crucial.co.uk
Operating System: Win7 home premium edition
Hard drive: Western Digital WD Black WD7502AAEX
Monitor: AOC i2353 connected by hdmi

Can anyone see a problem that i may have overlooked. Any help would be greatly appriciated.

thank you

More about : sapphire 7850 2gb

December 30, 2012 8:25:48 PM

try going into the graphics 3d settings of catalyst control center try setting 'wait for verticle refresh' to the setting just below 'quality'. This will force it ON unless a game turns it off.
!