Sign in with
Sign up | Sign in
Your question

7950 Not Showing in Device Manager

Last response: in Graphics & Displays
Share
December 31, 2012 1:34:07 AM

Hello all, I've been trying to get rid of Intel's integrated graphics on my system for a while now, and instead use my Radeon HD 7950. However, the Intel integrated graphics are the only option under display adapters in device manager. Is my GPU not being recognized? If so, how would I fix this? I do know the fans are spinning when I boot my computer. Anyway, if this can be fixed please let me know. If there is a solution, how would I switch from the Intel's graphics to my GPU's graphics?

Thanks guys.
December 31, 2012 1:36:51 AM

have you installed the drivers?
m
0
l
a b U Graphics card
a b å Intel
December 31, 2012 1:38:33 AM

in the bios should be an option to initialize the pcie card first. You may also want to assign an irq to it if you have that option available.
m
0
l
Related resources
December 31, 2012 1:45:05 AM

regularguy290 said:
have you installed the drivers?


Yes, I installed the drivers from the AMD site.
m
0
l
December 31, 2012 2:15:14 AM

popatim said:
in the bios should be an option to initialize the pcie card first. You may also want to assign an irq to it if you have that option available.


For whatever reason I couldn't see that in the BIOS.
m
0
l
December 31, 2012 4:16:18 PM

popatim said:
in the bios should be an option to initialize the pcie card first. You may also want to assign an irq to it if you have that option available.


I found this in the BIOS, initialized the PCI card like you said, but it still isn't recognizing the card. The only thing that shows up under device manager are the Intel graphics. When I disable them, I am running the Microsoft Basic Display Driver.
m
0
l
!