Sign in with
Sign up | Sign in
Your question

Catalyst driver won’t install on my PC

Last response: in Graphics & Displays
Share
December 31, 2012 5:44:08 PM

I just received a shipment of dell Optiplex 9010 Minitower Windows 7 computers (16 GB memory). General practice where I work is to wipe the hard drives and install our Enterprise version of Windows 7. The computers came installed with the new UEFI bios (which I had never seen before now). Standard practice would be to kill the pimary Wndows partition and re-install Windows on the clean partition, keeping the Dell System partition intact in the remote event we would want to restore it to factory default. However, UEFI would not let me delete a single partition. It made me delete all the partitions before I could manipulate them. All good I figured since I really didn't care about those 2 dell/system partitions anyhow. So... the re-install went flawless and everything works fine... except the ATI drivers won't install. The Dell-supplied card is an ATI Radeon 7570. The windows drivers work fine, but I need to install the Catalyst software for the users and dual-display funcionality. As it sits with the MS Widows drivers, it won't recognize dual displays. This is on ALL of the computers I did a clean install on (10 of them). The ATI software acts like it's installing and even says it comletes the install, but the drivers arn't present and the Catalyst software never gets installed. The install only takes about 10-15 seconds, so I know it'snot installing eveything. I would expect a full install to take at least a minute. I tried older Catalysyt drivers, beta drivers, everything. Nothing will install but I get no errrors anywhere. Not in the ATI log and not in the Windows logs. Could this have something to do with UEFI? In the bios the only video option is Dual Displays on or off. Either setting gives the same result. I checked the computers out before I wiped them (to make sure they booted) and they had the catalyst drivers installed before I wiped them. Anyone have any ideas? Any help would be greatly appreciated. Thanks in advance!
December 31, 2012 5:55:50 PM

Hi :) 

I cannot believe you didn't speak to Dell BEFORE you bought these...you are going to have to now...

As a guess, yes the towers will have UEFI Bios/Motherboards (ready for 8)

If you cannot disable UEFI, you are in serious trouble...speak to Dell...

All the best Brett :) 
m
0
l
December 31, 2012 5:58:44 PM

hello... could this be an Administrator problem? does the install show up in the program list? Control panel?
m
0
l
Related resources
January 1, 2013 6:55:28 PM

Brett928S2,

I didn't purchase them. Another branch did that I don't "directly" support. That essentially means I don't buy thier hardware, but I configure it for our domain, along with all of our Enterprise applications. What do you mean by "serious trouble"? Like I said, everything works fine except for the video (so far). However, it IS a little odd that they don't supply the ATI drivers for this model in the Dell support section, only the Intel drivers. And yes, I know they have UEFI on them already (no guessing), I'm just not familiar with it (as of yet) since I hadn't run into it before. Guess I'm in the process of "edjamukayshun".

IronSounds,

Not an administrator problem. I'm a domain admin (which has admin privs on all domain computers), plus I tell it to "Run as Admin" just by habit when I do pretty much anything nowadays. It does not show up in the installed programs list (or the CP), but if I try to run the install a second time, the ATI (AMD) Catalyst install application says it's already installed. I've gone trough the install location(s) under Program Files and Program Files (x86) and I can see that there are some files there, but not even close to what would be on a full install. I went ahead and installed the drivers I'm "trying" to install on a slightly older Optiplex with Win7 x64 and they install just fine.



This is a brain teaser for me. I hope this info helps with a solution. I know someone MUST have run into this before (or they will very shortly).


Cheers guy/gals, and thanks for the responses.
m
0
l
January 8, 2013 10:07:13 AM

*Solved*

It turns out to be a simple fix. I HAD to use the drivers from the Dell website. The AMD drivers would not install. This information came directly from AMD tech support. When I filtered on the Dell website for graphic card drivers for my serial #, only the Intel drivers would show up, so I mad the (incorrect) assumption that I had to install the AMD divers from the AMD website. Once I removed filtering from the Dell website and searched on "All downloads" I got the correct drivers. This would be the absolute *first* time that I couldn't get AMD graphic card drivers (or Nvidia for that matter) to install on an OEM card, and I've been doing this awhile. Anyhow, thanks for the responses.
m
0
l
!