Sign in with
Sign up | Sign in
Your question

Graphics Cards

Last response: in Graphics & Displays
Share
December 31, 2012 11:37:02 PM

I have installed a ATI Radeon HD 7570 into a Dell XPS 630i. I have installed the correct drivers from AMD. But the compute will not recognize the graphics card. What do I do?

More about : graphics cards

a b U Graphics card
December 31, 2012 11:56:36 PM

Have you tried downloading the latest drivers from their website? what Power Supply are you running? you can do a check with gpu-z or in the bios if the card shows up there then its definitely a driver problem i suggest you remove any old drivers from your p.c as they might be causing conflict with the new ones and have your anti virus software disabled when installing the drivers. . If i were you id just reinstall my OS (operating system e.g windows 7)
m
0
l
January 1, 2013 2:08:31 AM

haider95 said:
Have you tried downloading the latest drivers from their website? what Power Supply are you running? you can do a check with gpu-z or in the bios if the card shows up there then its definitely a driver problem i suggest you remove any old drivers from your p.c as they might be causing conflict with the new ones and have your anti virus software disabled when installing the drivers. . If i were you id just reinstall my OS (operating system e.g windows 7)


I have deleted all old drivers. I have downloaded the correct drivers for the 7570, I have reinstall the operating system. The power supply is a 750W from Dell. The original card was an Invida. What next?
m
0
l
Related resources
a b U Graphics card
January 1, 2013 4:38:33 PM

Can you play games on it? if yes then its just not recognizing the graphics card while you're on desktop
m
0
l
January 10, 2013 11:13:12 PM

I fixed the problem, I got a Nvida GTX 660 for my XPS 8500 and put the Nvida GTX 260 back into the XPS 630i and both systems are working perfect. Thanks for all the help.
m
0
l
!