Sign in with
Sign up | Sign in
Your question

GTX 660 shows display but not detected *frustrated*

Last response: in Graphics & Displays
Share
January 1, 2013 2:18:45 AM

Hi everyone, I recently built my first computer and for the most part it was a success. The only thing dampening my enjoyment of my new rig is that I'm having issues with the GPU. I originally had a MSI GTX 670 OC power edition and I could not get a signal so I RMA'd it and bought a EVGA GTX 660 in the meantime and to test it to see if it was indeed the GPU that was the problem. When I installed the GTX 660 it worked like a charm, everything was working properly for a few days. Now when I try to play any games the 660 is no longer being detected even though I'm getting a display thru the 660. I've tried clearing the C MOS, dvi, hdmi, all the pci slots, etc and I still can't get my system to detect the graphics card. What on earth could be the problem, I knew this came with the territory but this is ridiculous. Any ideas/solutions?

PC build specs:

Case/chassis: Cooler Master HAF 922 (updated)

CPU: Intel Core i5 3570k

CPU Cooler: Cooler Master Hyper 212 Evo

Mobo: ASUS P8Z77-V PRO

RAM: G Skill Ripjaws X 8 gb 1600

boot drive: Samsung 830 series 128 gb SSD

storage drive: Western Digital caviar black SATA III 7200 rpm 1 tb HDD

GPU: MSI GTX 670 OC power edition / EVGA GTX 660

PSU: Cooler Master Silent Pro Hybrid 850w

Optical Drive: Lightscribe 24x dvd drive

OS: Windows 8 64 bit
a b U Graphics card
January 1, 2013 2:35:43 AM

Odd question why did you go from a 670 to a 660..Just wondering
m
0
l
January 1, 2013 2:10:17 PM

determinologyz said:
Odd question why did you go from a 670 to a 660..Just wondering


I RMA'd the 670 and picked up a 660 in the meantime, it worked perfectly for a few days but now it's not being detected.
m
0
l
Related resources
January 1, 2013 2:18:37 PM

Did you install the latest drivers from Nvidia's site?
m
0
l
January 1, 2013 2:43:06 PM

payturr said:
Did you install the latest drivers from Nvidia's site?



Yes, when I installed the 660 for the first time it was detected and I downloaded the latest driver. Everything was working well for a couple of days, now the 660 is no longer detected but I still get a display.


m
0
l
!