Sign in with
Sign up | Sign in
Your question

Computer can't turn on after power outage. Help please!

Last response: in Systems
Share
February 19, 2013 1:11:42 PM

After a power outage I haven't been able to turn on my system. The system is based on an ASUS Maximus IV Gene-Z motherboard, an Intel Core i5 2550K Sandy Bridge processor, 4x4 GB 1600MHz HyperX RAM and a 460 GTX gfx, which have been running smoothly for almost a year now.

However, since the power outage I haven't been able to turn on the system. I've checked the voltage of my PSU and all levels are fine. I've changed gfx card and interchanged the RAM as well as trying only one stick of RAM - all to no avail.

When I put power on the PSU, the GO_led (for the go button) turns red for a couple of minutes before the lights turn on in the onboard Start and Reset button. However, it isn't possible to turn on the system by use of the start button, neither by short circuiting the PW swicth pins on the motherboard.

Lastly I've tried connecting the system to my laptop by the ROG connect. The laptop connects just fine and the RC Poster reads "Standby Power in". Tried to start the system på RC Remote but still nothing.

Any ideas that might help me solve this problem or just locate it, will be much appreciated.





(Sorry for reposting, but can't change the headline of my original post, which was a bit strange)
a b B Homebuilt system
February 19, 2013 1:19:17 PM

Do you have access to another power supply that you could swap into the system for testing purposes?

Also, what make/model of PSU are you currently using? And, was it connected to an UPS or a surge suppressor?
February 19, 2013 1:52:20 PM

You've measured the voltage I see, but the PSU could be damaged that there isn't enough current to power up your pc. I'd suggest get a new PSU and see what happens. It's better the PSU than is the motherboard.
Related resources
February 19, 2013 8:49:33 PM

I'll borrow a PSU from a friend of mine and get back to you guys. Thanks for your suggestions.
Actually the PSU is one of the only things that where the warranty has expired, so it wouldn't be awful if it was the motherboard instead, besides from the workload of replacing it :) 
February 19, 2013 8:59:11 PM

Try flipping the switch Off and then On on the PSU if you have one. That worked for me one time or another.
February 24, 2013 6:52:04 PM

Turned out it was the PSU. Just ordered a new corsair 650tx. Thx for your replies.
a b B Homebuilt system
February 24, 2013 8:00:49 PM

Kjelds said:
Turned out it was the PSU. Just ordered a new corsair 650tx. Thx for your replies.

Good job. Good luck with the new PSU. Have fun!
!