Sign in with
Sign up | Sign in
Your question

Black Screen After Windows Logo (ATI HD 6990M)

Last response: in Graphics & Displays
Share
January 2, 2013 9:45:23 PM

Graphics Card:

Radeon HD 6990M

No Overclocking



AMD Catalyst Driver Version, and Driver History:

Latest ATI drivers as well as drivers provided from the Sager website.



Operating System:

Windows 7 Ultimate 64 bit SP1



Issue Details:

The problem started while I was watching a video with VLC media player. I quickly paused then unpaused the video and suddenly the whole screen went black. After the screen went black there was no further hard drive activity.

Alt-tabbing and ctrl-alt-del'ing had no effect.

I restarted the computer and after the bios and windows logo screens the screen went black again.

I restarted in safe mode and uninstalled all amd drivers using Driver Sweeper 2.1.0, uninstalled CCC and uninstalled the device from the device manager. Then restarted. The screen works until I reinstall CCC with drivers (both Sager's drivers and the latest from AMD). I restart and the screen goes black again after the Windows logo. I also tried doing all the above plus manually deleting all ati drivers in the windows/system32/drivers folder.

Also, sometimes when starting the computer (instead of getting the black screen) I get a BSOD with an error in atikmpag.sys



Motherboard or System Make & Model:

Sager NP8170

MB: p170HMx



CPU Details:

Intel Core i7-2630QM

No overclocking



Motherboard BIOS Version:


Bios version: 1.01.10LS1

VBIOS: BR40793.004





System Memory Type & Amount:

8GB
February 6, 2013 1:34:37 AM

I have the exact same setup as you. And am running into the exact same problem besides getting the BSOD. Found anything out yet?
February 7, 2013 8:37:06 PM

Try the 12.10 drivers, they seem to be the most stable at the moment.
!