Sign in with
Sign up | Sign in
Your question

Gigabyte HD 7870 OC Black(ish?) Screen - Will not boot

Last response: in Graphics & Displays
Share
January 2, 2013 11:31:52 PM

Hi all,

First off, I apologize if this post is a bit... confusing, long-winded, or saga-esque (that's a word, right?). I have been slowly losing my mind, and my last shred of sanity is going into this post. :pt1cable: 

I have an issue (obviously). I just purchased a Gigabyte HD 7870 (This one--> http://www.newegg.com/Product/Product.aspx?Item=N82E168... <--) and... it hates me.

My original system (I'll explain in a sec) was:

AMD FX 8150 (Stock clock & mult) on an:
Asus Sabertooth 990FX with:
16GB Corsair RAM (4x4GB) and a pair of (disappointing):
XFX HD 6770s in Xfire powered by a:
Corsair G600 (600W) all connected to:
3x Acer 1080p 22in monitors - using an active displayport adapter to get the third to work.

It worked great, except the 6770 isn't exactly a powerhouse. So, I upgraded to the 7870 listed above.

I installed it into the above system (removing both 6770s of course) and it was happy for a while. The situation rapidly changed with a 0x1A MEMORY_MANAGEMENT BSOD. Power down. Reboot.. or try to, without luck.

If you don't know, the Sabertooth has diagnostic LEDs for each component during POST (I'm not sure how common this feature is, really.) It indicated a RAM failure, which was kinda expected, given the BSOD. I tried each stick individually in each slot. Nothing. It wouldn't POST at all, so I couldn't get into BIOS for any kind of diagnostic, much less run memtest. The monitors wouldn't even activate (because the GPU was never initialized... right?)

I realized it could be the RAM, Mobo, or even the CPU (mem controller - unlikely, but possible). Since CompUSA (Now tigerdirect) is a fair distance away from me, I decided go crazy and replace all three components. So now, I have a shiny new build:

AMD FX 8350 (Gotta have that extra 0.5GHz) on an:
Asus M5A99FX with:
16GB Corsair RAM (2x8GB) and
the (cursed) Gigabyte 7870 powered by a:
Corsair G600 (The same one)

Now, it will... kinda POST. If I allow it to POST and proceed with init, it craps itself. By that I mean: just after POST, it glitches, and falls back to a black screen with a thin blue horizontal line across it, about 10% of the way down the screen. The line is 1px high in the center, 2px on the edges. The best way to explain it is that it is about 3000px (on 1920x1080) wide - it starts near the end of one row of pixels, the entire next row is blue, and then 30% of the row after that is blue. Then it's all black. (I really hope that makes sense to someone?) It does not seem to continue with the boot. No HDD activity at least.

This only happens on one of the monitors, the other two never initialize. The monitor activated is the primary displayport monitor, if it is plugged in, or DVI if no DP connected.

However (and this is where I really get confused), if I immediately go into BIOS - I start hammering on the 'DEL' key as soon as I power it on - it has no problem. None at all. I can sit in BIOS indefinitely without it failing. But as soon as it goes to do a proper boot, it fails. Neither the 8350 nor the 990FX chipset have onboard VGA, AFAIK, so BIOS isn't running from that.

So I thought- power supply? Worth a shot. Upgraded to a Corsair HX850 (another lenghty trip to the store), with no change. So, not the PSU.

I reinstalled the 6770s, and it boots fine. Upated BIOS, tried the 7870 again... Nojoy.

Interestingly, when I install the original RAM into the new MOBO, it fails to boot, citing a DRAM failure, FWIW. So, it appears the RAM may actually have failed...

Maybe it was a GPU-RAM murder-suicide? Given my week, it's plausible, at the least. (I made a washing machine pee itself earlier this week - long and entertaining story I may share later)

I have an RMA with newegg, but until I figure out WTF is happening, I'm... hesitant to install another one. If anyone can shed some light on this, you will be my personal hero for at least a week.

FWIW I'm a computer engineer (CMOS ASIC designer and FPGA developer - academic research, not industry).

Thanks!
January 3, 2013 2:31:57 AM

Yeah, that was the pretty much the last thing I did... it did the same on my old 600W and on the new 850W.

And just because I know my stuff, it doesn't mean I always know what I'm doing lol
m
0
l
a b U Graphics card
January 3, 2013 4:15:14 AM

Given that. The GPU-RAM massacre seems like the likely scenario. Bad RAM most definitely.

Have you tried using the 7870 single monitor and making sure it receives all of its drivers on DVI cable.

Uninstalled previous 6770 drivers?

Clear CMOS on motherboards?

That's what I got for now.
m
0
l
January 4, 2013 2:13:24 AM

Yeah... doesn't change anything... I'm waiting on the RMA... if it happens with the new board, I'm going to have to try less conventional measures... [:lutfij:6]


I probably should have started by double-checking that my BIOS was truly up-to-date. Because it totally wasn't. It's taken me six months to bring myself to admit that.

So... case closed. Not sure why it initially worked and powered up fine. Maybe Catalyst did a firmware update on the GPU? Can it do that? But the BIOS update fixed it. Fortunately ASUS has a BIOS flash feature that doesn't require a live system to use - rips it straight off a flash drive before POST.
m
0
l
Related resources
!