GTX670 99% load when playing GW2

Hi guys, I just recently upgraded my GPU from a 460 to a 670. When I play Guild Wars 2, my 670 immediately jumps to 99% load and the game begins lagging noticeably. I find this strange because I experienced extremely minimal lag back when I was using my 460.

I have tried reinstalling the drivers and reinstalling windows with no avail.

My specs:
i7 2600k @ 4Ghz
MSI GTX 670 Power Edition
850W Silverstone PSU
16GB G.Skill RAM @ 1600Mhz
6 answers Last reply
More about gtx670 load playing
  1. Try a different driver.
  2. Thanks for the replies guys. I just tried crysis 2 with DX11 and high res textures enabled on max settings and although the card is at 99% load, there is no noticeable lag.
  3. Well with vsync off the card SHOULD run at 99-100%. If you turn on vsync or a frame rate limiter then the card won't run so hard, assuming it can pump out more frames than the set limit. What's your fps like in GW2?
  4. Roughly 61 FPS but I'm still getting lag for some reason :/
  5. In some games I have to use a framerate limiter to make it smooth. Skyrim and Metro 2033, for example. Otherwise everything is jerky when I move fast. Couldn't hurt to try.
  6. Whats the aa and af set to in game. This could just be a little glitch with the game and the driver. Try another aa setting. Normally turning it down a click will help, but sometimes even turning it up a click helps.

    Does that game have an option for MSAA or just SSAA?
Ask a new question

Read More

Graphics Cards Graphics