Sign in with
Sign up | Sign in
Your question

Nonfunctional usb 2 ports?

Last response: in Systems
Share
February 20, 2013 11:57:10 PM

Hey all. I just put a build together with the asrock H77m micro atx board, and everything is running smoothly, except a bunch of the USB 2 ports that come out the back are not working. Only 1 of them appears to be functional. Could this be a driver issue? Any suggestions?
February 21, 2013 1:10:33 AM

Yes, you need drivers. Go to asrocks website to download the "USB" drivers.
m
0
l
February 21, 2013 1:10:43 AM

might be a driver issue, use the driver disk that came with the mobo. it also just might be a broken mobo, if you are within the time limit you might want to try to RMA it
m
0
l
Related resources
February 21, 2013 1:14:19 AM

Watch out. For me, some USB ports not working was a sign of a dieing southbridge. If it progresses you may end up with no boot.

Try installing the drivers. If that fails, return the board while you still can.
m
0
l
February 21, 2013 1:23:29 AM

eyeage said:
FYI, if the drivers don't fix the issue, return the board asap, as the others are correct in that it's a sign of a defective board "if" the drivers don't fix the issue (I have a feeling they will). [/url=http://www.asrock.com/mb/overview.us.asp?cat=Download&o...] Here are the downloads for windows 7 64 bit. I am assuming that the USB that aren't working are actually 3.0 and not 2.0. The 2.0 should work without drivers.


it says in the title they are USB 2 ports, which leads me to strongly suggest you return the board and get a replacement
m
0
l
February 21, 2013 1:30:49 AM

gommer556 said:
it says in the title they are USB 2 ports, which leads me to strongly suggest you return the board and get a replacement



I agree, if the driver doesn't fix it, it's a bad board.
m
0
l
!