Sign in with
Sign up | Sign in
Your question
Solved

New SLi setup, rhythmic stutter with vsync enabled

Last response: in Graphics & Displays
Share
January 4, 2013 6:57:22 PM

Hey TH

I just installed a second GTX 680 into my system, and almost immediately noticed an aggravating problem. Let me preface this by saying that I've read as much as possible about the microstutter inherent in multi-GPU setups, and I'm not convinced that this is the problem that I'm experiencing.

When running games with SLi enabled, I experience a very fast framerate stutter precisely once every second. Fraps usually displays this as a rapid drop from 60 to 59 and back again in the blink of an eye. I'm finding that some programs run at 59fps with vsync and stutter to 58 and back. In game, it doesn't seem like a drop of 1fps - the game seems to freeze for a split second which is difficult to tolerate when there is fast action. This doesn't occur when I opt to run a game with one card. This happens in every game that I have tried (dozens) and the only thing I have been able to do is turn off vsync and set a frame limit of 60 or 62fps via Precision X. This results in screen tearing that is only slightly better than the maddening stutter.

My system specs:

i5-2500k oc'd to 4.6ghz
2x GTX 680's running at stock speed w/ nVidia drivers version 310.70
Asrock extreme3 gen3
8GB g.skill ripjaws x @ 1600
asus ve278q monitor @60hz
Windows 7 64bit

I have been trying to find a solution that will allow me to run games with vsync enabled and with a smooth, even framerate. Based on the rapid stutter every second and the fact that some apps seem to run at 59fps with vsync enabled, I wonder if it may be related to my monitor's refresh rate not lining up perfectly with the number of frames rendered every second.

Any help would be greatly appreciated!

Thanks
a c 185 U Graphics card
January 4, 2013 7:07:36 PM

I am not sure but i run sli 670 on 120hz and do not have that issue so maybe it is your monitor remember i am guessing here.
m
0
l
a c 134 U Graphics card
January 4, 2013 7:11:37 PM

Have you tried adaptive vsync its a bit less violent then normal vsync that may help you.
m
0
l
Related resources
a b U Graphics card
January 4, 2013 8:13:45 PM

try disabling fraps
also update your Windows and see if it did recognise your monitor make and installed the necessary drivers by itself...if not install it yourself.
also check if your psu is supplying enough power to both the cards.

it may be the psu issue too since it does not happen when you run only 1 card
m
0
l
a b U Graphics card
January 4, 2013 8:37:11 PM

Turn off vsync.

If you want to limit your framerate, use something like MSI afterburner. I use it set to 90fps maximum which works well. It's an arbitrary number I came up with after testing different values.
m
0
l
a c 134 U Graphics card
January 4, 2013 8:40:57 PM

With a NV card its just better to use Adaptive however that doesn't sound bad either that is a higher limit that wont bog down a card.
m
0
l
January 4, 2013 9:35:11 PM

Unfortunately it doesn't make any difference whether I use triple-buffering, in-app vsync, forced vsync (adaptive or otherwise) through the control panel, or whether fraps is running or not. I wish I could test it on a monitor with a higher refresh rate but that isn't an option at the moment.
m
0
l
a c 185 U Graphics card
January 4, 2013 9:39:52 PM

I do not know why you are having such a issue sorry man 670 sli with 120hz is awesome i wish you had a way to see what i mean hopefully somebody will reply with a answer that helps good luck!
m
0
l

Best solution

a c 134 U Graphics card
January 4, 2013 9:43:52 PM

Well unless you are coming across tearing I would say you are safe without vsync. However that being said you've read it its quite common in SLi setups to have stuttering. Maybe you could take one card out and see what happens. And perhaps take your CPU clock down. My feeling is whatever you are playing you are massively overpowering.
Share
January 4, 2013 10:14:44 PM

The tearing is pretty abysmal - if it wasn't it would be an easy decision. It's interesting that you should mention my CPU clock, though. The reason why I stopped overclocking at 4.6 was because anything above that would cause strange, periodic drops in framerate. I'll try lowering it a bit.

Edit: the framerate issues only occured in Starcraft 2, oddly enough
m
0
l
January 4, 2013 10:18:29 PM

bigshootr8 said:
Well unless you are coming across tearing I would say you are safe without vsync. However that being said you've read it its quite common in SLi setups to have stuttering. Maybe you could take one card out and see what happens. And perhaps take your CPU clock down. My feeling is whatever you are playing you are massively overpowering.


As I mentioned, selecting "single GPU" in the control panel for a particular program solves the problem. Anyone have any ideas on how I could test my PSU usage without a wall meter? All wattage calculators I used suggested that even with a 20% loss in efficiency over time, I would still have a bit of headroom (I'm running a Seasonic X-850)
m
0
l
February 17, 2013 5:01:41 PM

Glocktypus said:
As I mentioned, selecting "single GPU" in the control panel for a particular program solves the problem. Anyone have any ideas on how I could test my PSU usage without a wall meter? All wattage calculators I used suggested that even with a 20% loss in efficiency over time, I would still have a bit of headroom (I'm running a Seasonic X-850)



I wish there was resolution with this. I just bought a second GTX 660ti OC and when I got it going the flicker was intolerable. I am sending it back tomorrow if I don't resolve it here somewhere. Goodluck. I must say I am pretty happy with one 660. I wish I had a 120hz monitor. That will be what I get after paying this expensive SOB off. At least one year. The good thing is they just get cheaper when you wait.
m
0
l
May 7, 2014 8:10:55 PM

was this solved i'm having the same problem with my 680s i think. i get half way into a game and it starts stuttering for like 5 mins making it impossible to play sometimes i have to hold the power buttonn and restart
m
0
l
June 27, 2014 4:03:14 PM

If anyone struggling with the same problem happens to come across this thread, I finally figured it out! It turns out that f.lux was somehow responsible. Running games with two cards and vsync on while f.lux was running, even if the screen temperature wasn't changed, caused this rhythmic stutter. Closing f.lux while gaming completely fixed the issue for me.
m
0
l
2 minutes ago

Welcome to nvidia drivers my son. In general you have few options. One is no Vsync. The other is trying to force triple buffering with d3doverider however if your using windows 8 it generally doesn't work. It's a crap deal. Harass nvidia like I do all the time to fix their drivers and start adding all the fancy settings they have for OGL games for D3D.

Good luck :p . if it makes you feel better I have 4 titans and refuse to run without Vsync. This leaves me with the same issue. Miserable lag when my framerate faceplants due to not having triple buffering.
m
0
l
less than a minute ago

Has nothing to do with your overclocking btw. Nor should you have to "take out a card" lol. Nvidia needs to fix triple buffering with SLI is all. Until then u get to suffer or rig it.
m
0
l
!