Sign in with
Sign up | Sign in
Your question

GTX660 being out performed by a GTX260 (216)

Last response: in Graphics & Displays
Share
January 5, 2013 5:30:24 PM

I bought a new video card over the holidays upgrading from a BFG GTX260 (maxcore 216) to a Evga GTX660. On paper the GTX660 seems to be all around better. However with the games I play I'm just not seeing any sort of performance gain. I only play WoW, LoL, and Minecraft, which are not very graphically demanding games. WoW can be, however I find CPU/memory is much more important. In WoW performance was pretty much exactly the same, and in LoL and Minecraft I actually had a performance loss with the GTX660. In fact quite a big performance loss in Minecraft, about 25-30% lower FPS.

My current set up is Xeon 1230 V2, Asrock Extreme4, 16GB Kingston HyperX DDR1600, Intel 520 series 180GB SSD, dual monitors 1920x1080, and 1600x900.

I did a complete fresh install of the most current drivers available from Nvidia.

My unscientific non-perfect testing...

LoL tutorial intro:
GTX660 fluctuating between 118-132 FPS
GTX260 fluctuating between 125-144 FPS

In WoW standing idle at engineer AH in Shrine of Two Moons:
GTX660 fluctuating between 110-132 FPS
GTX260 fluctuating between 108-125 FPS

In WoW standing in Orgrimmar (moderately populated):
GTX660 fluctuating between 54-69 FPS
GTX260 fluctuating between 52-68 FPS

In WoW flying around in Kun-Lai Summit:
GTX660 fluctuating between 179-258 FPS
GTX260 fluctuating between 170-264 FPS

In Minecraft (Bukkit server running off the same computer, no one else connected):
GTX660 fluctuating between 120-166 FPS
GTX660 fluctuating between 161-242 FPS

Before I return this... Could there be a bottleneck that's causing me not to take full advantage of the GTX660, or is the card just not that much of an upgrade over my GTX260 (216)? If I threw some newer more graphically demanding games at it, than maybe I'd see the difference? However this still doesn't explain why I actually had a performance loss in LoL and Minecraft.
January 5, 2013 6:42:23 PM

pixelbat said:
I bought a new video card over the holidays upgrading from a BFG GTX260 (maxcore 216) to a Evga GTX660. On paper the GTX660 seems to be all around better. However with the games I play I'm just not seeing any sort of performance gain. I only play WoW, LoL, and Minecraft, which are not very graphically demanding games. WoW can be, however I find CPU/memory is much more important. In WoW performance was pretty much exactly the same, and in LoL and Minecraft I actually had a performance loss with the GTX660. In fact quite a big performance loss in Minecraft, about 25-30% lower FPS.

My current set up is Xeon 1230 V2, Asrock Extreme4, 16GB Kingston HyperX DDR1600, Intel 520 series 180GB SSD, dual monitors 1920x1080, and 1600x900.

I did a complete fresh install of the most current drivers available from Nvidia.

My unscientific non-perfect testing...

LoL tutorial intro:
GTX660 fluctuating between 118-132 FPS
GTX260 fluctuating between 125-144 FPS

In WoW standing idle at engineer AH in Shrine of Two Moons:
GTX660 fluctuating between 110-132 FPS
GTX260 fluctuating between 108-125 FPS

In WoW standing in Orgrimmar (moderately populated):
GTX660 fluctuating between 54-69 FPS
GTX260 fluctuating between 52-68 FPS

In WoW flying around in Kun-Lai Summit:
GTX660 fluctuating between 179-258 FPS
GTX260 fluctuating between 170-264 FPS

In Minecraft (Bukkit server running off the same computer, no one else connected):
GTX660 fluctuating between 120-166 FPS
GTX660 fluctuating between 161-242 FPS

Before I return this... Could there be a bottleneck that's causing me not to take full advantage of the GTX660, or is the card just not that much of an upgrade over my GTX260 (216)? If I threw some newer more graphically demanding games at it, than maybe I'd see the difference? However this still doesn't explain why I actually had a performance loss in LoL and Minecraft.


You have an Xeon cpu, Xeons weren't made for gaming and that could be the reason why your fps aren't changing
m
0
l
January 5, 2013 6:58:45 PM

pixelbat said:
I bought a new video card over the holidays upgrading from a BFG GTX260 (maxcore 216) to a Evga GTX660. On paper the GTX660 seems to be all around better. However with the games I play I'm just not seeing any sort of performance gain. I only play WoW, LoL, and Minecraft, which are not very graphically demanding games. WoW can be, however I find CPU/memory is much more important. In WoW performance was pretty much exactly the same, and in LoL and Minecraft I actually had a performance loss with the GTX660. In fact quite a big performance loss in Minecraft, about 25-30% lower FPS.

My current set up is Xeon 1230 V2, Asrock Extreme4, 16GB Kingston HyperX DDR1600, Intel 520 series 180GB SSD, dual monitors 1920x1080, and 1600x900.

I did a complete fresh install of the most current drivers available from Nvidia.

My unscientific non-perfect testing...

LoL tutorial intro:
GTX660 fluctuating between 118-132 FPS
GTX260 fluctuating between 125-144 FPS

In WoW standing idle at engineer AH in Shrine of Two Moons:
GTX660 fluctuating between 110-132 FPS
GTX260 fluctuating between 108-125 FPS

In WoW standing in Orgrimmar (moderately populated):
GTX660 fluctuating between 54-69 FPS
GTX260 fluctuating between 52-68 FPS

In WoW flying around in Kun-Lai Summit:
GTX660 fluctuating between 179-258 FPS
GTX260 fluctuating between 170-264 FPS

In Minecraft (Bukkit server running off the same computer, no one else connected):
GTX660 fluctuating between 120-166 FPS
GTX660 fluctuating between 161-242 FPS

Before I return this... Could there be a bottleneck that's causing me not to take full advantage of the GTX660, or is the card just not that much of an upgrade over my GTX260 (216)? If I threw some newer more graphically demanding games at it, than maybe I'd see the difference? However this still doesn't explain why I actually had a performance loss in LoL and Minecraft.


Probably the fact that you're gaming on an Xeon and are using DX10 on the 260, and DX11 on the GTX660. Also, it probably enabled Vsync so those extra FPS you arent seeing are going into keeping the frames synced and getting rid of screen tear. Youl see a diffrence when you go play an ACTUAL game that taxes GPU
m
0
l
Related resources
Can't find your answer ? Ask !
January 5, 2013 7:33:03 PM

austing said:
Probably the fact that you're gaming on an Xeon and are using DX10 on the 260, and DX11 on the GTX660. Also, it probably enabled Vsync so those extra FPS you arent seeing are going into keeping the frames synced and getting rid of screen tear. Youl see a diffrence when you go play an ACTUAL game that taxes GPU



Why would using a Xeon matter? E3 Xeon series is pretty much an i7 without the graphics controller and not unlocked. They work just fine dropped into a Z77 board. A lot of people are using them for gaming since the onboard graphics are pointless if you're using a discrete card, and you save like $60.

Anyhow... Vsync was not enabled. Thanks for the input.
m
0
l
a b Î Nvidia
January 5, 2013 7:54:04 PM

I have one of those processors in a gaming/work build. don't see a problem with it.

other poster has a point. DX10 vs DX11. try disabling DX11 attributes and see what happens.
m
0
l
a b Î Nvidia
a b Ý World of Warcraft
January 5, 2013 7:57:25 PM

try something a bit more demanding/newer. sometimes older cards do work better on older games. Play skyrim on both and see what one wins.
m
0
l
January 5, 2013 8:42:47 PM

pixelbat said:
Why would using a Xeon matter? E3 Xeon series is pretty much an i7 without the graphics controller and not unlocked. They work just fine dropped into a Z77 board. A lot of people are using them for gaming since the onboard graphics are pointless if you're using a discrete card, and you save like $60.

Anyhow... Vsync was not enabled. Thanks for the input.


Vsync isnt an option on Kepler GPU's that have adaptive Vsync, it comes on automaticly if the FPS is over the monitors refresh rate.
m
0
l
a b Î Nvidia
a b Ý World of Warcraft
January 5, 2013 8:53:33 PM

http://www.asus.com/Motherboards/Intel_Socket_1155/SABE...
there a warning that on z77 that server chips are going to disable some parts of the retail mb. it may be that your videocard is stuck in a slower 2x mode. i would also check that your mb bios is up to date..could be a code bug. also make sure your intel chipset drivers are up to date.
m
0
l
!