Sign in with
Sign up | Sign in
Your question

How do I useNvidia GT640 instead of Integrated GPU?!

Last response: in Graphics & Displays
Share
January 5, 2013 8:49:36 PM

Hey, so I've been doing quite a bit of reading around the web and I have managed to use my GT640 nvidia card when playing games (after some wrestling with the optimus tech) but I'd like to;

use the nvidia card as my default gpu so it will power things like google chrome and my desktop display!

One of the things driving me nuts is that I can't increase screen resolution because it won't let me switch to the nvidia card. Any advice?
a b U Graphics card
January 5, 2013 8:55:06 PM

kirival117 said:
Hey, so I've been doing quite a bit of reading around the web and I have managed to use my GT640 nvidia card when playing games (after some wrestling with the optimus tech) but I'd like to;

use the nvidia card as my default gpu so it will power things like google chrome and my desktop display!

One of the things driving me nuts is that I can't increase screen resolution because it won't let me switch to the nvidia card. Any advice?


When you start up the computer you can access your BIOS and turn of the integrated GPU and fully enable the 640.

Also, un-install the integrated drivers.
m
0
l
January 5, 2013 9:00:04 PM

Thanks for the quick response!

I will try to uninstall the intel drivers and post results shortly.

One question though; in the BIOS I was looking earlier and under the graphics options it only offered me 'integrated' or 'switchable as options.' Should that worry me?
m
0
l
Related resources
a b U Graphics card
January 5, 2013 9:07:15 PM

kirival117 said:
Thanks for the quick response!

I will try to uninstall the intel drivers and post results shortly.

One question though; in the BIOS I was looking earlier and under the graphics options it only offered me 'integrated' or 'switchable as options.' Should that worry me?


I'm not really sure as I've never had to disable a GPU in my BIOs, they're typically just plug and play.
m
0
l
January 5, 2013 9:24:04 PM

Alright new results. After going to the control panel and deleting the factory hardware I went to the device manager and uninstalled the Intel one leaving only my nvidia. After that it asked me to restart the computer so I did but when I turned it back on and opened the device manager it showed the intel card and the nvidia one side by side once again.
m
0
l
a b U Graphics card
January 5, 2013 9:27:12 PM

kirival117 said:
Thanks for the quick response!

I will try to uninstall the intel drivers and post results shortly.

One question though; in the BIOS I was looking earlier and under the graphics options it only offered me 'integrated' or 'switchable as options.' Should that worry me?


You should obviously use the Switchable option. And if you've managed to use the Nvidia card, it probably already has working drivers... which you may want to update, but I doubt the present problem is caused by outdated drivers.

Try these steps if you're still having trouble setting the Nvidia as default:
1st) Select the Video Nvidia Card in Display Properties, Apply and Accept without checking again till you have restarted the computer
2nd) Right click on My Computer icon> select Manage> Device Manager> find the Nvidia card and do a right click> and select Disable.
3) Shutdown the computer and switch the Monitor cable to the Nvidia card.
4) Restart and Enter the BIOS* (Pressing DEL or F2 or check**), select the Nvidia card (or Switchable) as the default video card, and configure related settings like type of socket and #Video MBytes (if any are present)... Exit the BIOS applying settings, and check again the Device Manager and Display Properties.

*If you don't have image during the computer startup (motherboard logo or BIOS post) just switch the monitor cable back to the motherboard port, and recheck the settings. You may need to apply 2nd setting first, followed by the 1st I mentioned on top.

**If DEL or F2 work, check the different key & combinations per computer makehttp://michaelstevenstech.com/bios_manufacturer.htm
m
0
l
a b U Graphics card
January 5, 2013 9:40:58 PM

kirival117 said:
Alright new results. After going to the control panel and deleting the factory hardware I went to the device manager and uninstalled the Intel one leaving only my nvidia. After that it asked me to restart the computer so I did but when I turned it back on and opened the device manager it showed the intel card and the nvidia one side by side once again.


Disable not Uninstall the factory hardware (video)... that just makes the Plug and Play service reinstall it on the restart. Also make sure that Display properties is not set to use two monitors, this will make the mouse dissappear on the side of the screen if you don't have two monitors connected.
m
0
l
January 5, 2013 9:40:59 PM

Sorry this is my fault for being a noob at these things but I should have laid a couple things out first.

The system is an Acer Laptop (Aspire V3)

CPU: Intel Core i7 etc etc
GPU: NVIDIA GeForce GT 640M with 2GB Dedicated VRAM
(onboard gpu: Intel HD Graphics 4000)

Anyway, it is a laptop so there's no monitor or cables to fiddle with.

Also the OS is Windows 8 so I'm not sure if that alters your replies.*

*The reason I wanted to post all that was that opening display properties didn't seem to give me the option to select the Nvidia card at all.
m
0
l
a b U Graphics card
January 5, 2013 9:44:42 PM

Just apply the settings that apply to a laptop and disregard the rest... it should work just the same.
m
0
l
a c 109 U Graphics card
a b Î Nvidia
January 5, 2013 9:52:34 PM

Some laptops you cannot disable the integrated, it's used for the laptop display and it won't work without out it, like that one...
What you can do is add the game(game.exe) in the nvidia control panel and use the "high performance nvidia processor" or pass to a monitor with hdmi...it will use fully the nvidia gpu.
m
0
l
January 6, 2013 12:03:07 AM

well that's unfortunate...I might as well invest in a nice monitor eventually and I have found other evidence that this problem would be solved if I used a second display. Thanks for all your help guys/gals!
m
0
l
!