Catalyst control center: host application has stopped working

Not sure whats left to do, every time I try to open CCC it first gives me:

"Load mmdriver aplication has stopped working"

and then it gives me this:

"catalyst control center: host application has stopped working"\

I've poured over many forums, and have yet to find a solution... Any help is greatly appreciated :)

more details below

Graphics card: radeon hd 7770 (HIS)

OS: vista home premium 32-bit

mmdriver problem details
Problem signature:
Problem Event Name: APPCRASH
Application Name: MMLoadDrv.exe
Application Version: 2.0.0.0
Application Timestamp: 5065f9d3
Fault Module Name: atiumdag.dll
Fault Module Version: 9.14.10.926
Fault Module Timestamp: 5064fef0
Exception Code: c0000005
Exception Offset: 003b8939
OS Version: 6.0.6000.2.0.0.768.3
Locale ID: 4105
Additional Information 1: 44c4
Additional Information 2: 156820caa092ae751238b86048999d40
Additional Information 3: b062
Additional Information 4: e1c7bef9ac17b02657331fefb9be020f

catalyst control center problem details
Problem signature:
Problem Event Name: APPCRASH
Application Name: MMLoadDrv.exe
Application Version: 2.0.0.0
Application Timestamp: 5065f9d3
Fault Module Name: atiumdag.dll
Fault Module Version: 9.14.10.926
Fault Module Timestamp: 5064fef0
Exception Code: c0000005
Exception Offset: 003b8939
OS Version: 6.0.6000.2.0.0.768.3
Locale ID: 4105
Additional Information 1: 44c4
Additional Information 2: 156820caa092ae751238b86048999d40
Additional Information 3: b062
Additional Information 4: e1c7bef9ac17b02657331fefb9be020f
3 answers Last reply
More about catalyst control center host application stopped working
  1. well its finally fixed and it only took a complete uninstall of vista and the installation of XP pro... not happy with vista...

    although im not sure if it was just vista though, as i found out that on a 32 bit operating system my motherboard couldn't actually use the full 4 GB of ram i have installed. Since my version of XP pro is 64 bit (and can use all 4 GB of ram) does that mean i couldn't run my graphics card on vista because it was a 32 bit operating system? :??: Im not convinced though because it was catalyst control center that wasn't working, not the graphics card...

    anyway, too anyone else having a similar problem i would suggest checking out the limitations of your motherboard. If your OS is already a 64 bit version of vista and the problem still persists, you may find switching operating systems will do the trick.
  2. go to amd.com and found the fix you probably have to ininstall ati restar pc and install software againg from amd.
  3. I probably installed/ uninstalled the drivers 10 times (or more), so trust me when i say that a re-install wouldn't have helped. (I even used device cleaner to completely start fresh a few times) thanks for the reply though :)
Ask a new question

Read More

Radeon Graphics Cards Catalyst Windows Vista Graphics