MSI AMD Radeon 7870 Display problem

Hello all,

This is my first post so bare with me. I just recently acquired an MSI AMD Radeon 7870. It runs all games wonderfully and I haven't had any freezing or BSOD's.

I recently set-up a dual display configuration, its configured in expanded setup. Both screens are 1080p. One is a TV and one is my main monitor.
Anywho, my problem is this, I have graphical glitching inside windows aero while playing videos. It doesnt matter if i'm using WMP or quicktime or VLC. I've tried a couple different driver versions and I dont seem to have any luck fixing the problem. I've looked inside Catalyst control manager, tried fiddling with some display settings and haven't had any luck there. I reported the problem to AMD and have had no reply. So... here I am. I've posted a picture of my start menu and what the glitch looks like. Any help is greatly appreciated.

-Brandon


7 answers Last reply
More about radeon 7870 display problem
  1. RMA it asap! Those glitches/artifacts are sign of a bad card. What are your temperatures at idle and at load?
  2. Anonymous said:
    RMA it asap! Those glitches/artifacts are sign of a bad card. What are your temperatures at idle and at load?


    Hmmm... Well that would suck... Then why would I only have the problem while running video on dual display? It's so specific.

    38c idle
    55c load
  3. Also it's only displaying it with AERO enabled.
  4. Oh yeah sorry, I didn't read it properly. Those temperatures are absolutely fine. Yes you are right it's an issue with dual display only. Hopefully the experts help you!
  5. Anonymous said:
    Oh yeah sorry, I didn't read it properly. Those temperatures are absolutely fine. Yes you are right it's an issue with dual display only. Hopefully the experts help you!



    Yeah, I've had bad cards before and these symptoms are nothing like that. I guess I was posting on here, hoping someone had the same issue and found a fix.
  6. I have the exact same problem. Two monitors, only when playing a video and only with Aero enabled. This has to be a driver bug of some sort, and I really hope AMD fixes it. If you figured out a solution and you could share it that would be great.
  7. n8tehgr8 said:
    I have the exact same problem. Two monitors, only when playing a video and only with Aero enabled. This has to be a driver bug of some sort, and I really hope AMD fixes it. If you figured out a solution and you could share it that would be great.


    You are correct. It was a driver issue. I uninstalled the old drivers using driver sweeper, then installed the latest driver from AMD. No more artifact!
Ask a new question

Read More

Radeon AMD Graphics Displays