Sign-in / Sign-up
Your question

Rate My Gaming Rig

Tags:
  • New Build
  • Systems
  • Product
Last response: in Systems

What rating would you give my build?

Total: 17 votes (6 blank votes)

  • 1/5
  • 0 %
  • 2/5
  • 0 %
  • 3/5
  • 19 %
  • 4/5
  • 55 %
  • 5/5
  • 28 %
February 24, 2013 12:04:48 AM

For the price I paid, how would you rate the following build?

PCPartPicker part list / Price breakdown by merchant / Benchmarks

CPU: Intel Core i5-3570K 3.4GHz Quad-Core Processor ($223.79 @ Amazon)
Motherboard: ASRock Z75 Pro3 ATX LGA1155 Motherboard ($74.99 @ Amazon)
Memory: G.Skill Ares Series 8GB (2 x 4GB) DDR3-1866 Memory ($54.99 @ Newegg)
Storage: Western Digital Caviar Blue 500GB 3.5" 7200RPM Internal Hard Drive ($59.99 @ Newegg)
Video Card: Galaxy GeForce GTX 670 2GB Video Card ($369.99 @ Newegg)
Case: Cooler Master HAF 912 ATX Mid Tower Case ($59.99 @ Amazon)
Case Fan: Cooler Master Megaflow 110.0 CFM 200mm Fan ($14.87 @ Amazon)
Power Supply: Corsair Builder 600W 80 PLUS Bronze Certified ATX12V Power Supply ($69.99 @ Newegg)
Total: $928.60
(Prices include shipping, taxes, and discounts when available.)
(Generated by PCPartPicker 2013-02-23 21:11 EST-0500)

My budget was $800. I was originally thinking about getting a build with the following combination of parts: i5 3570k, FX 8350, FX 6300, GTX 660 Ti, HD 7950, HD 7870. I knew I wanted my build to be based around one of these CPU/GPU configurations. I just wasn't sure which one to pick. After a few days of shopping on Ebay, I finally found an i5 3570k for $150 and a GTX 670 for $300.

I'm still waiting on my parts to arrive. Some of them are currently at the post office waiting to be picked up. I will probably begin building my PC on Monday.

More about : rate gaming rig

February 25, 2013 1:41:08 AM

Oh, I also only payed around $55 for that PSU. It was around the same price as its 500w sibling, so I said why not. I also caught the RAM on sale at Newegg for $45. I'm glad I grabbed it when I did.
February 26, 2013 3:54:37 AM

Finally finished building my rig. Still waiting for the audio driver to download. Then I have to download the driver for my GPU. A big thanks goes out to you guys on Tom's Hardware; you've been a huge help.

Not gonna lie, I did run into some trouble when I first tried booting. I tried plugging in a cable to the chassis fan header on the motherboard. I couldn't for the life of me figure out what I did wrong. After a bit of Googling, I finally found the culprit. I unplugged that particular cable from the motherboard, and everything fired up smoothly. Can't wait to get these drivers downloaded so I can play me some Skyrim. =D