Z77 Pro3 & Radeon 7870 -> no pic

Hello guys,

mind if I ask you what's the problem with my new PC?

Radeon 7870 isn't working (no pic to monitor). By integrated graphics it works fine.

I've updated Z77 Pro3's newest firmware and checked that PCI-E is working as primary buss. I changed also PCI-E Gen setting to value 1.

I've tried also with another PCI-E buss but it's still same problem. I've checked both additional power cables but it's not working.
Fan is spinning properly though.

Graphic card should work because my old PC was Asus P5QL Pro and C2D E6400 and it worked fine.

My specs:

Intel i5-3570k
ASRock Z77 Pro3
AMD Radeon 7870 2048 MB
8192 MB DDR3 1600 MHz
Nexus NX-5000

Thanks!
11 answers Last reply
More about pro3 radeon 7870
  1. what is your psu?
    try another psu if you have
  2. Would you think that is the best option? I don't have another PSU and I'm glad to know if there's something which can be fixed without updating whole component.
  3. Please list your PSU model.
  4. Nexus NX-5000
  5. Thank you, I see you listed that in your first post, sorry about that. If that PSU is working properly, the specs listed should be enough. That model does not have the best reviews though. Have you tried clearing your cmos?
  6. Yes I tried clear CMOS and I took off battery but it didn't help so far.
  7. I bought new Corsair 600W PSU but no picture still.
  8. I took motherboard out and built PC on table. Components I had were CPU, GPU, DDR and SSD. Result: failed, it didn't work.
  9. The Computer didnt work, or it didnt fix the graphics card issue?
  10. Sorry. It didn't fixed graphic card issue.
  11. It sounds like a bad gpu or motherboard then. If your sure the gpu works I would rma the board.
Ask a new question

Read More

Graphics Cards Radeon PCI Express Graphics