Sign in with
Sign up | Sign in
Your question

GTX 480 not working :(

January 6, 2013 9:29:14 PM

Good day to everyone! I'm a bit new here so please do bare with me with my understanding on my card's description.

I don't know what's the root cause of my GTX 480 and it's really gettin' into my nerves! I know this thread is a bit old and I have read some of the same issue but I need a confirmation from hustlers on what to do on my card.

First of all, my previous monitor was a Samsung 19" SA100 Syncmaster, native resolution is 1366x768, and I was trying to plug the card using a dvi-vga adapter sinbce the monitr has only a vga slot. The adapter is not working; tried to connect the cable to my mobo (ASRock z68 extreme4 gen3) and it worked perfectly. My first option was to replace my monitor thinking that it would not receive Digital signal even if I had an adapter (and also thinking that the adapter is faulty). So yes, I recplaced my monitor with a Dell E Series E1911 48 cm (19")W, and again disappointed, when I plugged the DVI-D cable with 18 pins to my gpu with DVI-I 24 pins, It didn't work :(  still in power saver mode and same thing when I plugged the cable into my mobo it still worked fine. I am using an ACBEL CE2 500w (max power 550), and has only one 8 pin connector and i just got a 6 pin cable to suffice the missing 6 pin socket from the gpu for supplemental power source.

Please give me some useful advice or am I missing something from my explanation? Or the problem is my Power supply not giving enough power, but the fan is working and heat sink is producing heat, I'm now tormented :( 

I would really appreciate any useful advice from you! :( 

More about : gtx 480 working

!