HELP! New built computer, no video, screen stays black

CPU: Intel core i5 3570k
Motherboard: Asus p8z77-v lk
Graphics Card: Nvidia Geforce gtx 560 ti
Memory: Corsair Vengeance 16GB black
Storage: Toshiba 1TB Hard Drive
PSU: Ultra LSP 650 watt ATX power supply
Optical Drive: Liteon 24x Internal DVD/CD Writer
Keyboard and mice: Logitech Wireless combo
Case: Corsair CC-9011014-WW Carbide Series 300R

I recently assembled my own pc and was working fine. Power, fans everything. When i connected the VGA cable from my monitor to my new computer, it worked fine but said: "no keyboard found" and "cpu fan error"
So, I unboxed my keyboard and mouse and plugged in the usb, then it said: insert bootable device" installation something...

So i put in my motherboard cd which didn't work because i have to get into the bios to set it to first boot but my keyboard wasn't working.

Next, i opened up the case again and looked for the usb 2.0 connectors when i tried, all the cables got in the way so i tried moving them around. I also did some stuff on the motherboard looking for the connectors, like reseating some stuff because all the cables were jotting in the way. I didn't know what to do then, so i turned the comp back on and then there was no display on the monitor. The vga connection was fine but the screen was black and the power indicator led was flashing slowly.

Please help
2 answers Last reply
More about help built computer video screen stays black
  1. Okay, did you already have some of these components prior to all of them being put together? Also, is your CPU fan connnectd to the CPU fan header?
  2. bigshootr8 said:
    Okay, did you already have some of these components prior to all of them being put together? Also, is your CPU fan connnectd to the CPU fan header?


    Yes i did and yes the cpu fan is connected to the cpu fan header
Ask a new question

Read More

Graphics Cards Graphics