Sapphire 7850 flickering and black screen

Hi, I own a Sapphire 7805 OC edition 2gb GDDR5, the problem is when it goes into its high performance mode in games on my monitor weird bars flicker. its hard to explain but only happens when it is in high performance mode. after about 10 minutes of gaming my monitor black screens and the gpu crashes and i need to reeboot my pc.
i have tried the beta drivers fir amd catalyst, (i used driver sweep to remove th old ones). I have also tried the last stable set of drivers. I have reinsatlled a fresh copy of windows and updated my mobo bios, none of this works.

CPU: intel i3 3200
RAM: kington 8gb ddr3
PDU ocz500w 80+
GPU: sapphire 7850 oc 2gb
MOBO: gigabyte z77-ds3h

Thanks in advance guys, im sooooo confused
8 answers Last reply
More about sapphire 7850 flickering black screen
  1. And its just happened again whilst playing Planetside 2
  2. keep an eye on the gpu temps.
    also disable any auto oc or tuning tools you might have installed.

    revert if it works or not
  3. siddharthmukul007 said:
    keep an eye on the gpu temps.
    also disable any auto oc or tuning tools you might have installed.

    revert if it works or not

    My gpu temps are fine they get t a max of about 60 degrees whilst gaming.
    And I do not have any tuning software
  4. your psu as well as all others seems fine...try your card on another machine and if the problem continues...RMA your card
  5. RMA the card :( My 7870 had the same issues, it would crashes whenever I gamed. I traded it in for a Msi 660ti! The 78xx series AMD cards are know to get black screen crashes! They "said" they fix them, but the problem is still there and they still sell the old ones sometimes!
  6. I have actually heard (you can check some of the comments where Sapphire actually responded to feed back on new egg) that Sapphire had a bad batch of cards that went out. It should have been correct on new cards but who knows if vendors actually sent back there stocks and Sapphire replaced or if just waiting for people to RMA there cards to replace them.
  7. Yea I think this may be it, i'm gonna RMA the card. ;(
  8. Got it swapped out, issue is still happening, Could it be because I am using a vga to dvi connector
Ask a new question

Read More

Graphics Cards Performance Sapphire Graphics