Sign in with
Sign up | Sign in
Your question

Experiencing some performance issues with the GTX 670

Tags:
  • Graphics Cards
  • Gtx
  • Performance
  • Graphics
Last response: in Graphics & Displays
Share
January 7, 2013 5:51:54 PM

Hey guys, so I recently upgraded from a 6850 XFX card, which really was not cutting it for me, so I decided to upgrade to the new EVGA 670 GTX (not the FTW model.). After having to return the card a couple of times due to it being faulty, I finally was able to purchase one that would work with my computer. When I installed all the drivers and made sure everything was working I tried the card on Battlefield 3, and it worked amazingly with everything on ultra at 60+ fps.

However once I tried it out with games such as Borderlands 2 with the Physx turned to high as well as Saints Row the Third, I began to imediantly notice some performance issues, with BL2 fluctuating between 20-50 fps in tough battles and saints just going crazy between 20-40 fps.

I have been experiencing this with multiple other games too especially on Physx supported titles, however those were the ones that I noticed the most performance issues on.

Im thinking that my CPU might be bottlenecking my GPU however I was told that my i5 should barely bottleneck the card by any means.

My Build:

i5 3450 3.1ghz (OC'd to 3.5ghz)
ASrock b75m MotherBoard
8 gb Kingston DDR3 Ram
EVGA 670 GTX 2Gb
650 watt powersupply (I forget the brand)

So yeah, I have been troubleshooting this for hours getting no where, and really its not that I am getting very low fps in games, however when you spend $400 on a graphics card you expect 400 dollar performance.

More about : experiencing performance issues gtx 670

January 7, 2013 5:56:42 PM

Does you FPS improve when you turn off Physx? When you try lower settings?
m
0
l
January 7, 2013 5:58:40 PM

When I turn down Physx I do notice a small FPS gain, however when I lower the settings (specifically on Saints Row and Borderlands 2) it doesnt help with my performance in the slightest.
m
0
l
January 7, 2013 6:55:36 PM

Is your PhysX set to Auto? it my be trying to use your GPU for PhysX and the game. I do know that the PhysX isn't very well implemented on BL2, so maybe setting it to your CPU to control PhysX will help. Also try turning down AA to 2x if you are running that as well.
m
0
l
!