Sign in with
Sign up | Sign in
Your question

Willing to donate for good explanation

Last response: in Graphics & Displays
Share
January 7, 2013 7:30:47 PM

Well today i installed my 7950 Sapphire OC With boost, i slapped in the 12.11 Drivers etc and then player Far cry 3 it hit 15 FPS i was like WTF ?

So tried Dirt 3 it hit 30FPS Maxed out i was LIKE NO WAY

So i uninstalled 12.11 Drivers fully and went back onto Dirt 3 and hit 130FRAPS Maxed fully out. Re-installed the 12.11 rivers and boom i hit 30Fraps again ?

Battlefield 3 runs SWEET on Ultra but not far cry 3 or Dirt 3, im presuming there is something wrong :o 
Could it be a bottleneck ?

Specs : ASRock 970 Extreme 3
16GB Vengeance Ram 1600MHz
AMD II x4 945 @ 3.0 ( Still lags even when i OC my CPU )
60GB OCZ SSD
CX600 Corsair PSU
7950 Sapphire Vapor-x 3GB OC With boost
W&D 1TB HDD @5200RPM
January 7, 2013 7:33:17 PM

Far Cry 3 you need the CAP profile.

AMD Catalyst Application Profiles 0.5 MB 12.11 CAP 2 12/3/2012
Description:
This release of AMD Catalyst™ delivers support for the latest AMD CrossFireX™ and AMD Enduro™ profiles in a separate executable file ensuring users have access to the absolute latest set of profiles installed on their PC.

New profiles added to this release:
- Improves Far Cry 3 performance for single GPU configurations with AA enabled



Method:

1) Download Driver Fusion HERE.
2) Download Catalyst 12.11 beta11 drivers HERE. but don't install.
3) Download Catalyst 12.11 CAP 2 HERE
4) Custom uninstall all AMD software through Control Panel, select everything and reboot.
5) Run Driver Fusion and clean AMD display drivers - reboot.
6) Re-install CCC and reboot.
7) Install the CAP profile and reboot.
January 7, 2013 7:34:50 PM

RussK1 said:
Method:

1) Download Driver Fusion HERE.
2) Download Catalyst 12.11 beta11 drivers HERE. but don't install.
3) Download Catalyst 12.11 CAP 2 HERE
4) Custom uninstall all AMD software through Control Panel, select everything and reboot.
5) Run Driver Fusion and clean AMD display drivers - reboot.
6) Re-install CCC and reboot.
7) Install the CAP profile and reboot.

Im going to try right now. I will LOVEEEE you if this works
Related resources
January 7, 2013 7:35:13 PM

Could be a couple of things, but definitely not bottleneck.

1. You downloaded drivers for wrong operating system or card (very unlikely imo).
2. You have your old card driver remnants.
3. You've got something running in the background that shouldn't be and is interfering with drivers (like anti virus interested in driver activity).

My suggestion would be clean install of windows. Since you've got a new card, a fresh start will make sure you don't have troubles like the one you're having.
January 7, 2013 7:40:51 PM

Sunius said:
Could be a couple of things, but definitely not bottleneck.

1. You downloaded drivers for wrong operating system or card (very unlikely imo).
2. You have your old card driver remnants.
3. You've got something running in the background that shouldn't be and is interfering with drivers (like anti virus interested in driver activity).

My suggestion would be clean install of windows. Since you've got a new card, a fresh start will make sure you don't have troubles like the one you're having.

I get an error with driver fusion saying to delete all drivers from AMD please upgrade to premium
January 7, 2013 7:41:06 PM

Sunius said:
My suggestion would be clean install of windows.


??

TheGamblerUK said:
I get an error with driver fusion saying to delete all drivers from AMD please upgrade to premium


You shouldn't have to.

Here:

http://treexy.com/products/driver-fusion
January 7, 2013 7:46:28 PM

TheGamblerUK said:
Thanks it worked. PS When i install CCC should i pick custom or express ?


Express... just custom when uninstalling.
January 7, 2013 7:50:32 PM

RussK1 said:
Far Cry 3 you need the CAP profile.

AMD Catalyst Application Profiles 0.5 MB 12.11 CAP 2 12/3/2012
Description:
This release of AMD Catalyst™ delivers support for the latest AMD CrossFireX™ and AMD Enduro™ profiles in a separate executable file ensuring users have access to the absolute latest set of profiles installed on their PC.

New profiles added to this release:
- Improves Far Cry 3 performance for single GPU configurations with AA enabled



Method:

1) Download Driver Fusion HERE.
2) Download Catalyst 12.11 beta11 drivers HERE. but don't install.
3) Download Catalyst 12.11 CAP 2 HERE
4) Custom uninstall all AMD software through Control Panel, select everything and reboot.
5) Run Driver Fusion and clean AMD display drivers - reboot.
6) Re-install CCC and reboot.
7) Install the CAP profile and reboot.

Just done everything you guys have said and the same problem is occurring.
This is really stressing me out now.
January 7, 2013 7:56:22 PM

TheGamblerUK said:
Just done everything you guys have said and the same problem is occurring.
This is really stressing me out now.


What settings and resolution?

What's the cpu usage like while in game?
January 7, 2013 8:01:08 PM

RussK1 said:
What settings and resolution?

What's the cpu usage like while in game?

1920 x 1080 Also my CPU only goes to like 60%
January 7, 2013 8:03:20 PM

TheGamblerUK said:
Just done everything you guys have said and the same problem is occurring.


You could not have reinstalled windows so fast :) .
January 7, 2013 8:04:11 PM

Sunius said:
You could not have reinstalled windows so fast :) .

Not windows, my windows is 2 days old. I installed windows 2 days before my card came and only downloaded, Skype, RocketDock, and a few other things.
January 7, 2013 8:09:22 PM

Did you install Windows on the SSD with the HDD still plugged in?
January 7, 2013 8:10:18 PM

chugot9218 said:
Did you install Windows on the SSD with the HDD still plugged in?

Nope took out the HDD then put the HDD in after install
January 7, 2013 8:11:34 PM

Is Far Cry 3 updated to 1.04?
January 7, 2013 8:14:01 PM

chugot9218 said:
Did you install Windows on the SSD with the HDD still plugged in?


What does that have to do with anything?
January 7, 2013 8:15:50 PM

TheGamblerUK said:
Not windows, my windows is 2 days old. I installed windows 2 days before my card came and only downloaded, Skype, RocketDock, and a few other things.


Do those other things include drivers for your old GPU? :p 
January 7, 2013 8:18:52 PM

Sunius said:
Do those other things include drivers for your old GPU? :p 

I dont think it has old drivers on i have no idea but i dont have a clue where to start with it
January 7, 2013 8:27:31 PM

TheGamblerUK said:
I dont think it has old drivers on i have no idea but i dont have a clue where to start with it


BF3 works fine? FC3 is buggy... I had to mess with settings to get it going ok... still funky but playable and will get worked out eventually either through drivers, UbiSoft or both. Make sure it's patched to v.1.04 though.
January 7, 2013 8:35:28 PM

RussK1 said:
BF3 works fine? FC3 is buggy... I had to mess with settings to get it going ok... still funky but playable and will get worked out eventually either through drivers, UbiSoft or both. Make sure it's patched to v.1.04 though.

You know what i give up on this ****ing thing its driving me MADDD

I just dont get how when i uninstall then it works fine

Oh and btw i just tried running Far Cry 3 on Low Settings and it ran at exactly 4.2FPS LOOOOOOL i had to restart
January 7, 2013 8:42:45 PM

TheGamblerUK said:
You know what i give up on this ****ing thing its driving me MADDD

I just dont get how when i uninstall then it works fine

Oh and btw i just tried running Far Cry 3 on Low Settings and it ran at exactly 4.2FPS LOOOOOOL i had to restart


Seems like the card isn't entering into 3D clocks thus staying in a low-power state.

In CCC turn up the slider for power controlsettings to +20. Go into Windows Power Options and make sure it's in High Performance mode.

You did install the 12.11 CAP 2 profile right?
January 8, 2013 5:53:43 AM

RussK1 said:
Seems like the card isn't entering into 3D clocks thus staying in a low-power state.

In CCC turn up the slider for power controlsettings to +20. Go into Windows Power Options and make sure it's in High Performance mode.

You did install the 12.11 CAP 2 profile right?

Ahhhhhhhhh right right, i think you will know how to fix this. I OC my Core to 1010 and the fraps went up to 50 but then i noticed in Afterburner my GPU Usage was at 0%
Also my Memory from my Card stayed at 121MB when it should be hitting WAY WAY WAY higher than that.

Its like that game is blocking my memory.
January 8, 2013 6:19:30 AM

install 12.10 whql driver, if already using these, set everything to default settings and restart the system. disable your antivirus program and please disconnect from internet, try playing the game and reply, after that.

also your rest system configuration, that could help more to sort out your prob.
January 8, 2013 10:38:02 AM

TheGamblerUK said:
Ahhhhhhhhh right right, i think you will know how to fix this. I OC my Core to 1010 and the fraps went up to 50 but then i noticed in Afterburner my GPU Usage was at 0%
Also my Memory from my Card stayed at 121MB when it should be hitting WAY WAY WAY higher than that.

Its like that game is blocking my memory.


Make sure the clocks are set to stock in Afterburner and apply. Is it reporting your card?
January 8, 2013 11:07:47 AM

Start far cry 3 the open ccc and check if core clock not stuck at 500mhz...i had this problem...after trying far cry my core clock always stuck at 500 mhz giving like 11 fps in far cry( gigabyte wind force 7950).so i disabled hardware acceleration,downloaded msi afterburner and overclocked 900->1100 mhz 1250->1450 and now All fps over 60 like 80 all settings max msaa x8..
January 8, 2013 1:58:42 PM

amateur1337 said:
Start far cry 3 the open ccc and check if core clock not stuck at 500mhz...i had this problem...after trying far cry my core clock always stuck at 500 mhz giving like 11 fps in far cry( gigabyte wind force 7950).so i disabled hardware acceleration,downloaded msi afterburner and overclocked 900->1100 mhz 1250->1450 and now All fps over 60 like 80 all settings max msaa x8..

Ahhhhh well after burner says 950MHz core and the Memory at 1250MHz but CCC Says 300 Core and 150 Memory
January 8, 2013 2:06:20 PM

Check afterburner graph, not the slider area.
January 8, 2013 2:16:03 PM

tried disabling hardware acceleration?
January 8, 2013 2:24:55 PM

TheGamblerUK said:
Ahhhhh well after burner says 950MHz core and the Memory at 1250MHz but CCC Says 300 Core and 150 Memory


Run Kombustor and check the clocks. The 300/150 are idle clocks which is normal.
January 8, 2013 2:29:32 PM

amateur1337 said:
tried disabling hardware acceleration?

Right everyone, i have WIPEEDDDD fully all my drivers etc EVERYHING im installing 12.11 again now and if this doesnt solve it can someone teamviewer me pretty please ?
January 8, 2013 2:31:43 PM

can now announce that my GPU Clock is now stuck at 501MHz

This is really really stressing me out like MADD :o 
January 8, 2013 2:35:41 PM

I'll do it. PM me your id and password
January 8, 2013 6:58:17 PM

Did you disabled hardware acceleration?
a b \ Driver
January 8, 2013 7:40:38 PM

...and thats why I have 2 installations of win7 on the same machine. One I can try out beta drivers and the other is whql only. As someone already mentioned - dump those beta drivers and stick to the certified ones until you get this resolved. Theres no sense compouding problems you may or may not have with buggy drivers.
!