Sign in with
Sign up | Sign in
Your question

PLEASE HELP: My Computer turns on but no display ! I tried everything.

Last response: in Systems
Share
February 25, 2013 7:01:04 PM

I bought all the parts 2 days ago and I already assembled my computer I tried to look for beep codes and when i took off the ram and just started the computer, the beep code was 1 long 2 short.

The computer seem to have no display at all
I have no video card so i'm assuming i am using the onboard video card which is the intel graphic 2500
The computer turns no no problem. the fans are running including the cpu fan

" i am a first time builder"
" ive been looking for solutions for the past 2 days and i stuck"

PLEASE HELP AND I APPRECIATE IT



My Specs are :

Hardrive = 1 x Seagate Barracuda ST2000DM001 2TB 7200 RPM SATA 6.0Gb/s 3.5" Internal Hard Drive -Bare Drive

Case and Powersupply=1 x Rosewill R519-BK Black ATX Mid Tower Computer Case w/ 500W Power Supply

Ram= 1 x G.SKILL Value 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-1600C11D-16GNT

Motherboard= 1 x ASUS P8Z77-V LK LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard with UEFI BIOS

Processor= 1 x Intel Core i5-3570 Ivy Bridge 3.4GHz (3.8GHz Turbo Boost) LGA 1155 77W Quad-Core Desktop Processor Intel HD Graphics ...

More about : computer turns display

February 25, 2013 7:43:37 PM

I tried both breadboarding and the steps on the first link
Related resources
February 25, 2013 9:30:18 PM

Where the beep sequences right? Like when you just had the MoBo and processor hooked up just one long beep? and so forth because if the bios beeps are in right, right off the bat you have a pad PSU, CPU, or MOBO.
February 25, 2013 9:37:56 PM

without ram the beep squence is 1 long 2 short
when everything is plugged in, there are no beep sequence.

the bios should be in right. at slot 1 and 2. and there are 3 slots/pins

1. the psu spins and runs.
2. the led light is on on the motherboard.
3. cpu should be fine. its brand new and i tried it on my friends computer
February 25, 2013 10:23:08 PM

do you guys think its the power supply? i some recommend me changing the power supply on other forum sites
February 26, 2013 3:23:07 AM

aandyxp said:
without ram the beep squence is 1 long 2 short
when everything is plugged in, there are no beep sequence.

the bios should be in right. at slot 1 and 2. and there are 3 slots/pins

1. the psu spins and runs.
2. the led light is on on the motherboard.
3. cpu should be fine. its brand new and i tried it on my friends computer


Without ram you mean nothing plugged into the board but the CPU and heatsink fan? No monitor plugged in nothing plugged into the back panel only thing plugged into the motherboad is the PSU, CPU, heatsink fan, and a power switch from the case, and your getting One long and 2 short

Well one long and 2 short is a error in the video somewhere a video card seated wrong or cable loose somewhere, usually, some bios can be different though, since your not using a video card I'd check your cables are screwed tight. Otherwise I would say your MoBo is junk if the onboard video has a problem. Do you have a video card of any kind you could try?

"the bios should be in right. at slot 1 and 2. and there are 3 slots/pins" I have no idea what this means.
March 5, 2013 6:43:25 PM

UPDATE: I RMA'D IT BACK TO NEWEGG AND THEY SAID THERE ARE SEVERAL SEVERELY BENT PINGS IN THE CPU SOCKET ! IS THAT WHY MY COMPUTER HAD NO DISPLAY
March 5, 2013 9:33:52 PM

aandyxp said:
UPDATE: I RMA'D IT BACK TO NEWEGG AND THEY SAID THERE ARE SEVERAL SEVERELY BENT PINGS IN THE CPU SOCKET ! IS THAT WHY MY COMPUTER HAD NO DISPLAY



I would say thats it, better luck on the next one, make sure you have the arrow corner on the cpu lined up with the arrow corner on the MoBo next time.
!