Sign in with
Sign up | Sign in
Your question

Facry 3 FPS question

Last response: in Graphics & Displays
Share
January 8, 2013 6:20:15 AM

I just bought a Sapphire HD 7950. Today I installed it and started to play Farcry 3 and I noticed that my framerate seemed really low. I loaded up fraps and my FPS seems to stay around 30-45 fps and sometimes dipping to 25. I've tried overclocking and lowerng the settings and it stays the same.


Specs:

Phenom II 955 @3.8
Sapphire HD 7950
8 gigs ram
XFX 850 watt psu
MSI N750-g55 mobo


I was thinking it might be a CPU bottleneck, but I've found other people with the same CPU running at much higher FPS on Ultra.

Does my FPS seem normal? Thank you for any help.

More about : facry fps question

a b U Graphics card
January 8, 2013 6:24:03 AM

How much memory does your graphics card have?

Also, what graphics settings are you using?
m
0
l
Related resources
a b U Graphics card
January 8, 2013 6:53:13 AM

gamingboy said:
Do note that his CPU is overclocked high and he's running a 7950, which according to the benchmark, gets about 30 FPS on Ultra.


When the architecture is bad, then the overclock doesn't mean as much.

Ultra settings could be with MSAA left off, the OP hasn't told anything about that.

Though the 955 will still bottleneck, because the 955 will also be pushed further if settings get cranked up, it's not only the GPU.
m
0
l
January 8, 2013 6:56:01 AM

I've tried Ultra with MSAA on and off. I get the same results.

Edit: Looking at t hat graph it does seem to be the CPU bottlenecking. Could you guys recommend a cpu that would work with my mobo and be a good upgrade? I've always had problems finding information on bios upgrades for the mobo so I'm not sure what it supports now.
m
0
l
a c 160 U Graphics card
January 8, 2013 6:58:16 AM

Thats normal for Far Cry 3, its very new and for now it kills GPUs. Just installed the latest CAP from AMDs driver download page, that helps a bit I have noticed.
m
0
l
January 8, 2013 7:00:37 AM

Novuake said:
Thats normal for Far Cry 3, its very new and for now it kills GPUs. Just installed the latest CAP from AMDs driver download page, that helps a bit I have noticed.


I forgot to mention that I'm on thwe new drivers with the Farcry CAP installed.
m
0
l
a c 160 U Graphics card
January 8, 2013 7:02:37 AM

Tismo said:
I forgot to mention that I'm on thwe new drivers with the Farcry CAP installed.


As the guys said, your processor even though heavily OCd is old and will be slower than modern CPU at the same clock rate. Your FPS numbers are totally normal. I am not getting much better and I ahve my 3570K at 4.6GHz.
m
0
l
a b U Graphics card
January 8, 2013 7:02:42 AM

lostgamer_03 said:
When the architecture is bad, then the overclock doesn't mean as much.

Ultra settings could be with MSAA left off, the OP hasn't told anything about that.

Though the 955 will still bottleneck, because the 955 will also be pushed further if settings get cranked up, it's not only the GPU.


Tismo said:
I've tried Ultra with MSAA on and off. I get the same results.


Then it's an CPU bottleneck. The FPS you are getting is pretty much the max you would be getting anyway on your card, you might gain a few more FPS from switching your CPU.
m
0
l
a b U Graphics card
January 8, 2013 7:06:16 AM

Tismo said:
I've tried Ultra with MSAA on and off. I get the same results.

Edit: Looking at t hat graph it does seem to be the CPU bottlenecking. Could you guys recommend a cpu that would work with my mobo and be a good upgrade? I've always had problems finding information on bios upgrades for the mobo so I'm not sure what it supports now.


I wouldn't bother. Just stick with your current CPU, and upgrade when you're starting to hit bigger bottlenecks.
m
0
l
January 8, 2013 7:20:37 PM

Turns out my CPU was at 3.7. I've never touched the voltage before today, but I want to see if I could squeeze some more FPS out of my cpu.

I have upped it to 1.4v @4.0ghz
m
0
l
a c 160 U Graphics card
January 8, 2013 7:54:51 PM

determinologyz said:
http://megagames.com/news/radeon-hd-cards-suffer-spikey... might be a cause to


Please read THE WHOLE story before spreading that. It is true that there is a latency issue, BUT it is not as real world affecting as most people have now started believing and TechReport has said this themselves.

http://techreport.com/review/23981/radeon-hd-7950-vs-ge...
http://techreport.com/review/24022/does-the-radeon-hd-7...
http://techreport.com/review/24051/geforce-versus-radeo...
http://techreport.com/blog/24133/as-the-second-turns-th...

The drops he is experiencing is not consistent with what TR has found, those are natural drops that the GTX660ti would encounter in certain situations too.

EDIT : Here is a nice lengthy discussion for you to read too.

http://www.tomshardware.com/forum/forum2.php?config=tom...
m
0
l
a b U Graphics card
January 8, 2013 8:04:55 PM

Novuake said:
Please read THE WHOLE story before spreading that. It is true that there is a latency issue, BUT it is not as real world affecting as most people have now started believing and TechReport has said this themselves.

http://techreport.com/review/23981/radeon-hd-7950-vs-ge...
http://techreport.com/review/24022/does-the-radeon-hd-7...
http://techreport.com/review/24051/geforce-versus-radeo...
http://techreport.com/blog/24133/as-the-second-turns-th...

The drops he is experiencing is not consistent with what TR has found, those are natural drops that the GTX660ti would encounter in certain situations too.

EDIT : Here is a nice lengthy discussion for you to read too.

http://www.tomshardware.com/forum/forum2.php?config=tom...


Just saying
m
0
l
a c 160 U Graphics card
January 8, 2013 8:09:18 PM

determinologyz said:
Just saying


:D  I am just saying too.
m
0
l
January 8, 2013 8:49:57 PM

Just thought I'd post some graphs during gameplay to see if they match my FPS. 2xMSAA and SSAO.





m
0
l
January 9, 2013 9:27:43 PM

I'm getting low FPS in Hitman Absolution as well. I think I'm going to look for a new CPU. Hopefully one that will work with my mobo.

Edit: Something I forgot about. I was lazing when I installed the card. Instead of formatting and reinstalling windows I just used Driversweeper. Is there a chance that reinstalling and formatting could help?

Edit2: I'm considering getting this CPU, but I'm sure I would need to get a new mobo as well.

http://www.newegg.com/Product/Product.aspx?Item=N82E168...
m
0
l
!