Sign in with
Sign up | Sign in
Your question

Reinstalled OS, won't let me access my data drive (D:\users\myolduid)

Last response: in Windows 7
Share
March 15, 2012 7:07:20 PM

I'm in some desperate need of help.

My OS froze this morning and couldn't be recovered. My configuration:

1. Hardware - Toshiba Qosmio i7 +++
2. Windows 7 Home Professional installed on SSD -- my software drive
3. Separate hard drive for data, default user directory

I had to wipe and reinstall the OS on the SSD. Having had previous bad experience with Toshiba Qosmio recovery disk, I removed my user director (data drive) first.

I created the user Admin -- with administration rights.

Via regedit, I changed my default user profile drive.

On my data drive (D:) , I changed my old user file from myUID to myUID.old -- so there would be no potential conflict.

I created my new UID -- with full administrator rights.

I logged on as me, went to D:\users and attempted to access D:\users\myUID.old so that I could move the data contents of the directory to my new home directory.

I received message that I don't have permissions to access -- but was given opportunity to continue as Administrator. I clicked continue.

Still no access privileges.

I right clicked on the top level directory, went to properties, into security... advanced -- and I can't take control of privileges at all -- everything is grayed out.


How do I regain access privileges on my computer where I am the Administrator???


Thank you for your help!
March 15, 2012 7:37:33 PM

Cogence said:
I'm in some desperate need of help.

My OS froze this morning and couldn't be recovered. My configuration:
...


I tried ...

SET DIRECTORY_NAME="D:\Users\myUID.old"
TAKEOWN /f %DIRECTORY_NAME% /r /d y
ICACLS %DIRECTORY_NAME% /grant administrators:F /t


That failed. Access denied.
m
0
l
a b $ Windows 7
March 15, 2012 7:41:36 PM

Are you checking the drive properties or the folder it self for the security tab?

If you take the drive, you can force propagation of the ownership to all folders on the drive.
m
0
l
Related resources
March 15, 2012 7:50:58 PM

I did it both for the drive and the top level folder itself. The end result is the same. When I click on the top level folder I am told that I have been denied access to this folder. Clicking into the security tab, there is no way for me to change security.
m
0
l
a b $ Windows 7
March 15, 2012 7:58:24 PM

screen shot?

very strange.
m
0
l
a b $ Windows 7
March 16, 2012 2:04:29 AM

I will guess you got to that with just

Right click
Properties
Security
Advanced
Permissions

What do you have under Owner?


m
0
l
March 16, 2012 2:55:19 AM

I found the problem. Just Microsoft once again mistakenly thinking they can write operating systems.




"You receive a Windows 7 access denied error when accessing a folder through Windows Explorer even though you have set the permissions correctly. You are an administrator and the administrators groups have full control over the folder but you can’t access it without Windows re-writing the permissions.

The cause of this is because of a new feature in Windows 7 called User Access Control (UAC). It is the combination of UAC and a bug in Windows Explorer that causes the access denied error.

..."

Thank you so much nukemaster.
m
0
l
a b $ Windows 7
March 16, 2012 3:25:52 AM

I am glad you got it fixed.

I have moved drives about and so far not run into that issue.

UAC has been on since Vista, so it must suffer the same possible issue.
m
0
l
March 16, 2012 3:42:49 AM

From the link, it appears to be 64 bit specific bug and "ONLY affects the Administrators group". I have multiple systems for different purposes and upgrade for one reason or another fairly frequently. I've never run into this before.

Having been a Unix admin, once upon a time, and having worked on the Mach microkernel, this kind of issue tends to send me into an anti-MS rant. Of course, then I settle back down into MS because that's where all my tools operate. Sigh.

Many thanks again!
m
0
l
!