Sign in with
Sign up | Sign in
Your question

No signal, no post, some signs of power

Last response: in Systems
Share
February 27, 2013 3:39:44 AM

Let me begin by admitting my fault. I wanted to disconnect my ethernet cord, but I was too impatient to power off the device and get behind it, so I slid the machine abit forward to grab the cord. When I did this the front legs of the computer slid off the desk and the bottom of the case thudded with the edge. The computer powered off when this happened.

Afterwards, the computer powered on as normal, however, maybe 10 minutes after being on the computer shut itself down. I tried to power it on again, and this time it lasted even less. I opened the case to ensure everything was plugged in fine and I tried powering it on one last time. This time I got no signal to the monitor and no beeps, although fans start fine.

I went through this thread that I found helpful when I first built the PC:
http://www.tomshardware.com/forum/261145-31-perform-ste...

I have tried using a brand new PSU from a classmates computer, and it gave the same results. I've tried different monitors and no change. I tested my RAM and GPU on another device and both work fine. Sadly, I cannot test another CPU on the device as most of my classmates use laptops and the few with desktops are AMD users.

I have tried resetting CMOS with the jumpers as well as removing the battery. I reseated my CPU. I removed all RAM and tried booting without any RAM. I tried with 1 RAM stick in each slot. I've tried using the onboard monitor connection. I have fully dissembled the computer and reassembled to ensure all cords, screws, and what have you are in their proper places.

To outline the state of my PC:
Powers on. Fans start (CPU fan stutters at the start). No beeps. No signal to monitor. Reset button does not function. Lights indicating power on the GPU display.

Since this started with the bump, I am positive this is my fault. However, is there anything else I can do to test the device? What is most likely the culprit, the CPU or motherboard? Is there anyway to test these two without a separate CPU?

Thank you for your time!

My build is as follows:
ASRock Z68 PRO3 GEN3 LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
Intel Core i3-2120 Sandy Bridge 3.3GHz LGA 1155 65W Dual-Core Desktop Processor Intel HD Graphics 2000 BX80623I32120
G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model
ASUS ENGTX560 TI DCII TOP/2DI/1GD5 GeForce GTX 560 Ti (Fermi) 1GB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI
a b B Homebuilt system
February 27, 2013 9:50:12 PM

Well I'd suspect motherboard but not sure exactly why that would have been damaged. Have you tried powering on the mobo with nothing but CPU and one stick of RAM installed using your original power supply? and then with borrowed? that right there could help eliminate if it is YOUR power supply or not.
m
0
l
March 2, 2013 4:06:09 PM

I have tried a simple setup of only motherboard, CPU, and one stick of RAM. I know the PSU and RAM are working as I use them in a separate setup.
m
0
l
Related resources
!