Sign in with
Sign up | Sign in
Your question

No POST or video output!

Last response: in Systems
Share
February 27, 2013 5:35:10 AM

I have been through the checklist of what to do in case of no POST beep.

This is my first build and I was quite exact with everything I did.

I breadboarded the components and got a POST, my monitor showed 'No boot device connected. Reboot and connect boot device'.
I built the computer in the case, but had a problem where it would not boot at all. I discovered there was a grounding problem and fixed that.

It turned on, case fans, gpu fans, cpu fan and lights turned on. But it wasn't outputting any video.
I have all of the power connectors plugged in correctly the same as when it POSTed outside of the case, but to no avail.

Taking all of the parts back out and starting at the same point I initially did also didn't help. Nor did resetting the CMOS and taking out the CMOS battery. I've tried both my RAM modules separately and in each slot.

I am stumped.

I am using:
Gigabyte Z77 MXD3H MB
XFX HD 7870
ThermalTake 700W TR2
Intel i5 3570

Please help.

More about : post video output

a b B Homebuilt system
February 27, 2013 11:47:59 AM

Depending upon the grounding issue you had, a component such as the PSU or motherboard, ram or CPU even... may have been damaged. You can check to see if the PSU provides power, you can remove all ram and see if you get ram error beeps, if you get though that fine, then I would think RMAing the motherboard would be the next step... don't explain about why (you suspect) it doesn't work, just that it worked and now it doesn't work. I will recommend beginning an RMA dialogue with Gigabyte.
Just to clarify that there are no burn marks on the motherboard since that could be considered 'user induced damage' and would likely not be covered by warranty.
!