Sign in with
Sign up | Sign in
Your question

Catalyst Control Center: Install Package failure

Last response: in Graphics & Displays
Share
January 9, 2013 4:58:18 PM

Yesterday i went and bought an XFX hd 6870 to crossfire with my asus hd 6870, so i plugged the graphics card in and connected the bridge. when i was going to start up my CCC it wouldnt start up, so i uninstalled the software and drivers, did a driver sweep and then reinstalled, and since then I'm getting the "Install Package failure" error.

I've searched quite a bit, and found many answers, but none of them has worked for me.
I have done a complete removal of the software and drivers.
I have uninstalled vcredist 2010 before installing the software.
I have ran the installer as administrator before installing the software.

Also notable: Everything exept CCC or Visual engine something is installed after i run the installer. I just need CCC to enable crossfire between the 2 cards.
I will probably reinstall windows if i cant get this to work.

Asus HD 6870 - EAH6870
XFX HD 6870 - HD-687A-ZDFC
Corsair HX850
MSI 990FXA-GD65

Please help? :) 
January 10, 2013 5:23:04 AM

bump, nobody has an answer? i really dont want to do a fresh windows install
January 31, 2013 8:40:04 PM

OK, I've just fixed this a few minutes ago. Bit of a nightmare... really. Who ever wrote this should be shot. No idea if this will help you, but well.. I hope so.

I'd been mucking with a new install, and had just moved around drive mappings - used to have a G:D rive and now no more.

When trying to install it would fail on CCC and the transcoder piece

In event viewer -> windows logs -> application there was a nice fat error saying

"Product: AMD Accelerated Video Transcoding -- Error 1327.Invalid Drive: G:\"

Went to regedit, searched for "G:\" and found four links to docs, photos, videos and music. Pretty innocuous. Anyway I manually changed all four to point to my E:\ drive, where I keep that stuff now. Closed regedit, ran install - went through straight away.

Hope it helps.

Related resources
August 7, 2013 5:05:03 PM

i got the catalyst "install package failure" message as well (new XP install). And i needed to install "Visual C++ 2005 Redistributable Package (x86)" for it to work. Perhaps do 2010 for good meaasure too...
!