Sign in with
Sign up | Sign in
Your question

New build-Display driver stopped responding and has recovered

Last response: in Graphics & Displays
Share
January 10, 2013 5:21:26 AM

hello. i just put together my new build today and i have a gtx660. the problem is that twice now it has said this error Display driver stopped responding and has recovered. once when i quit the game crysis 2 and the other when i was getting my windows pc score. also, at random times the screen will get broken up and the display will get all choppy and then clear up after 30 seconds. Do i have a defective graphics card? i doubt my setup is running hot. what can i do to find the problem and any thoughts would be nice. I have windows 8 64 professional.
Thank you
a b U Graphics card
January 10, 2013 6:22:12 AM

get drivers updated for your card...WHQL certified ones.

also check the error logs on the event viewer for more information.

and revert back if the problem persists after the update.
m
0
l
January 10, 2013 6:28:51 AM

I had already downloaded the latest drivers from the website before this problem occurred.
m
0
l
Related resources
a b U Graphics card
January 10, 2013 6:40:03 AM

check the error log on event viewer...and revert back.

many a times various other software conflicts also leads to these problems.

also update Windows.

btw did you make a clean install of windows 8 or updated it directly from your previous os?
m
0
l
January 10, 2013 10:03:23 PM

This was a clean windows 8 install. many people seem to be having the same problem with different answers. some people say its the motherboard and others messed with the settings. I am so lost as to what to do. I have all the latest drivers for my video card and the problem still persists when i load into battlefield 3 and 2 minutes of playing. The screen breaks up and gets choppy and it freezes and my computer resets
m
0
l
a b U Graphics card
January 10, 2013 11:26:09 PM

Try reseting your bios back to defaults.
m
0
l
a b U Graphics card
January 11, 2013 7:19:32 AM

You can also try to see if a BIOS update of your card works out
m
0
l
!