Sign in with
Sign up | Sign in
Your question

7850 DVI Not Recognised

Last response: in Graphics & Displays
Share
January 10, 2013 11:57:04 PM

Hey guys


I recently swapped out my 5770 for a 7850, before this I uninstalled my ATI Drivers, ran driver sweeper, then installed the new drivers. But when I plugged the new card in it doesn't appear to be recognised. It is connected to my monitor via VGA Cable with a DVI adapter, but whenever I plug card end of the cable into a DVI port either on the card itself or on the motherboards DVI port the monitor will sit in Power Saving mode. The only way to actually see the display to remove the adapter and run VGA/VGA. So far I have reseated the card, used a different adapter and enabled PCIE first in the BIOS but nothing has solved this problem.


The monitor is an LG Flatron W2242S should it matter.

More about : 7850 dvi recognised

January 11, 2013 12:01:22 AM

I forgot to add, I suspected either the Card or PCIE port to be dead. But the card is on with the fans spinning when the computer is on.
m
0
l
March 19, 2013 6:51:17 AM

I have exactly the saem problem but with dual monitor, trying to connect it to the card using dvi to vga connector. Tried to dial phone for AMD helpline, of course is dead as well.

m
0
l
Related resources
March 19, 2013 6:51:17 AM

I have exactly the saem problem but with dual monitor, trying to connect it to the card using dvi to vga connector. Tried to dial phone for AMD helpline, of course is dead as well.

m
0
l
March 19, 2013 6:51:17 AM

I have exactly the saem problem but with dual monitor, trying to connect it to the card using dvi to vga connector. Tried to dial phone for AMD helpline, of course is dead as well.

m
0
l
!