Sign in with
Sign up | Sign in
Your question

Driver issues for games in windows 7 64 bit.

Last response: in Windows 7
Share
March 16, 2012 3:27:58 PM

Hi guys! Thanks for taking the time to read this.

Recently ive gotten more into PC gaming, so I built a system with a 6770 hd and a phenom x2 555 with win7 64 bit. Games run pretty well with the drivers I got from the disk (8.841), except there was sometimes some slowdown in some games such as Skyrim - every 10-15 seconds the frame rate would fall dramatically (this happened with portal 1 as well so its not a case of putting the settings too high either!). Anyway I decided to update the drivers to 8.950 and instantly the problem was taken care of - or so I thought. In all games the frame rate became steady, however, although some games run perfectly fine, Skyrim has weird artifacts appearing on the screen and Assassins creed revelations has a problem where if you look up the screen goes mucked up. Also you can see through Ezio.

So what can I do here? If I go back to my original drivers ill have the annoying frame rate issue, and with these newest drivers some games have become unplayable. So are there any good drivers you guys can recommend, or is there something else wrong which is causing these issues?
March 16, 2012 9:15:36 PM

Are the Skyrim artifacts the little pixels around candles and such? I got that too after newest upgrade with 6770.

My 6770 is nothing but problems with Win 7 and games. I'm preparing to return it right now.
March 19, 2012 9:28:02 AM

turboknee said:
Are the Skyrim artifacts the little pixels around candles and such? I got that too after newest upgrade with 6770.

My 6770 is nothing but problems with Win 7 and games. I'm preparing to return it right now.


Ahhh you have issues with it as well? I temporarily had a 6670 hd and that worked fine with skyrim.

The artifacts pop up everywhere, on all textures, and there is even a square artifact on the floor that follows me around. I though it was a mucked up version of my shadow at first but it is separate. Well I think ill just go back to my original drivers until I can work out a fix. Thanks for the input!
!