Sign in with
Sign up | Sign in
Your question

Catalyst Control Center, cant install

Last response: in Graphics & Displays
Share
January 12, 2013 1:24:55 AM

Yesterday i went and bought an XFX hd 6870 to crossfire with my asus hd 6870, so i plugged the graphics card in and connected the bridge. when i was going to start up my CCC it wouldnt start up, so i uninstalled the software and drivers, did a driver sweep and then reinstalled, and since then I'm getting the "Install Package failure" error.

I've searched quite a bit, and found many answers, but none of them has worked for me.
I have done a complete removal of the software and drivers.
I have uninstalled vcredist 2010 before installing the software.
I have ran the installer as administrator before installing the software.

Also notable: Everything exept CCC or Visual engine something is installed after i run the installer. I just need CCC to enable crossfire between the 2 cards.
I will probably reinstall windows if i cant get this to work.

Asus HD 6870 - EAH6870
XFX HD 6870 - HD-687A-ZDFC
Corsair HX850
MSI 990FXA-GD65

Please help?
!