AMD Radeon HD 5850 compatibility issues with ASUS M5A78L LE

Yesterday i bought a brand new ASUS M5A78L LE motherboard to replace my old one P5NE-SLI. I have an AMD Radeon HD 5850 graphics card and it was fully functional with the P5NE-SLI, but it's not working with my new motherboard. I didn't change my PSU so it's not the problem from the PSU (850W). I've checked everything the wire connections, the RAM, the PSU, everything. When i started up the system with my new motherboard and the HD 5850 i got one long beep and three short beeps which means that there is no VGA. I had an old AMD Radeon 2000 series gfx card (i don't remember the exact model) and i put this card in. The system started up without the beeps and i had graphics, but a very bad resolution. I installed the drivers and again the resolution was bad. I've also intalled the latest BIOS version and still nothing with the HD 5850! Please help me!! I want to know how can i make the Radeon HD 5850 to work with my system!

My computer specs:
CPU: AMD FX-8120 3.1GHZ 8-CORE
PSU: 850W (i don't know the brand)
RAM: Geil 1600MHz 4GB(2x2GB)
Motherboard: ASUS M5A78L LE
GPU: AMD Radeon HD 5850 (which i want to make it to work with the system)

Please help me!
18 answers Last reply
More about radeon 5850 compatibility issues asus m5a78l
  1. Check that gpu in others pc.your mobo is compaitable with any gpu.
  2. ASHISH65 said:
    Check that gpu in others pc.your mobo is compaitable with any gpu.

    I've checked the gpu and there is no problem. I don't know what's going on. I knew that my mobo is compatible with any gpu, but i have this problem.
  3. Then its clear that mobo 's pci exp slot is faulty.replace that mobo.
  4. ASHISH65 said:
    Then its clear that mobo 's pci exp slot is faulty.replace that mobo.

    Right now i borrowed an nvidia GT-315 gfx card and it's working with full resolution, but i have a interferences and i don't know from where!! Probably as you said the PCI Slot is faulty.
  5. You mean nvidia card worked.have plugged 6pin connected to hd 5850 from psu.
  6. ASHISH65 said:
    You mean nvidia card worked.have plugged 6pin connected to hd 5850 from psu.

    The nvidia card worked, with interferences as i said before. This card has not six pin connection it gets the current from the slot. My PSU is fully functional.
  7. I mean you need 2 x 6pin connector from psu to connect hd 5850.
  8. ASHISH65 said:
    I mean you need 2 x 6pin connector from psu to connect hd 5850.

    Yes i need 2x6pin connector to connect the HD 5850 and i have them.
  9. Without pluging gpu is your system starts?
  10. ASHISH65 said:
    Without pluging gpu is your system starts?

    Yes it starts, but with no gfx cause there is no internal gfx card.
  11. now conclusion is

    1)your mobo is fine
    2)gpu is fine
    3)your psu is fine

    there is a compability issue i think so related to bios.can you give me webpagr of your mobo bios downloads page
  12. ASHISH65 said:
    now conclusion is

    1)your mobo is fine
    2)gpu is fine
    3)your psu is fine

    there is a compability issue i think so related to bios.can you give me webpagr of your mobo bios downloads page


    Here is the page: http://www.asus.com/Motherboards/AMD_AM3Plus/M5A78L_LE/#MSL (in the download section i choose windows 8 64 bit)
  13. Try disabling the on board graphics in the BIOS.
  14. Dude download and update bios from this not from memory support

    - http://www.asus.com/Motherboards/AMD_AM3Plus/M5A78L_LE/#download

    hope this will solve your problem
  15. ASHISH65 said:
    Dude download and update bios from this not from memory support

    - http://www.asus.com/Motherboards/AMD_AM3Plus/M5A78L_LE/#download

    hope this will solve your problem

    I've downloaded and updated the BIOS from this page http://www.asus.com/Motherboards/AMD_AM3Plus/M5A78L_LE/#download and not from the memory support. What you told me before to disable the on-board graphics, i go to the advanced tab and then chipset and there says "internal graphics" and i enter. I can't find anything to disable. I don't have on-board graphics.
  16. ok so after updating bios it worked or not?
  17. ASHISH65 said:
    ok so after updating bios it worked or not?

    The same again it didn't work.
  18. Really hard to tell whats the problem.ok i just update if i got a solution.
Ask a new question

Read More

Radeon HD AMD Motherboards Graphics