Sign in with
Sign up | Sign in
Your question
Closed

XFX 7870 GHz Edition - Far Cry 3 problem

Last response: in Graphics & Displays
Share
January 14, 2013 11:06:53 PM

I had just recently purchased the XFX 7870 GHz/Black Edition from Newegg to upgrade my system from my dual 6770s. I bought it after hearing that it can play certain games maxed out just fine, including Far Cry 3. Well upon plugging it in, getting the new drivers, and firing up the game, it ran great ~60fps no problem with everything at Ultra settings and all DX11 features enabled. But the next day when I went to go play the game again, i'm getting around 30fps... and I have to turn some settings down. What is going on? I snooped around and some people suggested I get the 12.11 beta Catalyst drivers, so I did that. Still not any better, despite it saying in the description that FarCry 3 was a target for improvement...

I just don't understand how it worked flawlessly maxed out the first day, and now it's not... other games still run just as good at max compared to the day one install with this new card. Only FC3 is really suffering here. I am at a loss, somebody throw me a bone here before I blow my brains out. I know i'm being anal about FPS but I was on the fence about buying this unless it played FC3 flawlessly, and it did... at first. :fou: 
a b \ Driver
January 14, 2013 11:56:00 PM

I don't think you got 60 FPS with an HD 7870 with everything at Ultra. That goes against all the benchmarks I have seen.

http://www.tomshardware.com/reviews/far-cry-3-performan...

http://www.guru3d.com/articles_pages/far_cry_3_graphics...

Much closer with everything on High not Ultra.

http://www.techspot.com/review/615-far-cry-3-performanc...

All assuming you are playing at 1920 x 1080 with a decent CPU. Since you don't list complete system specs it's hard to say. Far Cry 3 is really the only game out there stressing higher end cards right now.
Score
0
January 15, 2013 12:10:40 AM

anort3 said:
I don't think you got 60 FPS with an HD 7870 with everything at Ultra. That goes against all the benchmarks I have seen.

http://www.tomshardware.com/reviews/far-cry-3-performan...

http://www.guru3d.com/articles_pages/far_cry_3_graphics...

Much closer with everything on High not Ultra.

http://www.techspot.com/review/615-far-cry-3-performanc...

All assuming you are playing at 1920 x 1080 with a decent CPU. Since you don't list complete system specs it's hard to say. Far Cry 3 is really the only game out there stressing higher end cards right now.

Sorry I forgot to mention other specs:

Phenom II X6 1090T 3.2GHz - O.C. 3.5GHz
ASUS M4A88TD-V EVO/USB3 mobo
4x4GB 16GB G.Skill 1600MHz
60GB OCZ Vertex 2 SSD SATA II
1.5TB Samsung EcoGreen HDD SATA II

But anyway, Idk man. I read the reviews for this card on Newegg and people said it could run it maxed no problem at stock OC settings. And when I first launched the game with this card, I tweaked everything to Ultra and it was smooth as butter. I know benchmarks dont lie, but I dont get it. The ONLY thing that dropped my frames noticeably was notching the Vsync setting from "1 Frame" to "2 Frames"
Score
0
Related resources
January 15, 2013 12:16:09 AM

I would say those reviews on Newegg were full of sh*t, but the fact of the matter was i HAD everything on Ultra at one point, and it was fine. :o 
Score
0

Best solution

January 15, 2013 12:45:26 AM

some settings may not take effect until the game is restarted. that is probably what happened. you turned all the settings up and played the game, and ran fine. then you rebooted, and all of a sudden the graphics are actually turned up due to the restart.
Share
January 15, 2013 12:49:02 AM

iam2thecrowe said:
some settings may not take effect until the game is restarted. that is probably what happened. you turned all the settings up and played the game, and ran fine. then you rebooted, and all of a sudden the graphics are actually turned up due to the restart.


*facepalm* I feel like that could be it. Sounds about right... Well, now i feel less crazy :pt1cable: 
Score
0
January 15, 2013 12:58:32 AM

Best answer selected by Br0chure.
Score
0
January 21, 2013 1:36:08 AM

Hey bud,
I had a similar issue like you. I'm running 1x 7950 on 2560x1440 monitor and had about half drop in FPS one day. I have a Phenom 960T unlocked to 6 cores over clocked to 3.7 and it looked like it was using all my cores, but only at about %50. The GPU wasn't working very hard at all either. It was like the game didn't now how to delegate the work load with 2 extra cores. I disabled the 2 of them and ran just a 4 core with a higher clock (3.9ghz)and it is using about 90%+ of my cpu and kept my GPU core at max as well. This about doubled my FPS. I don't think the game likes a 6 core that much. Gained a huge FPS on just 4 cores. See if you can disable a couple cores on your Phenom....Might get a higher clock too!
Score
0
!