Sign in with
Sign up | Sign in
Your question
Closed

New build, Boots ASROCK screen and then nothing...

Last response: in Graphics & Displays
Share
January 15, 2013 4:32:48 AM

I hope this is in the right section, I apologize if its not. Just got done building, booted up, all fans turn on, graphics card fans turn on, dvd drive works, but the screen just shows the "Asrock preliminary boot screen" (the one that prompts the BIOS) then goes blank(everything seems to continue running). I have tried pressing "delete" f6 ect but I only have a bluetooth keyboard so im not sure that the usb receiver is even picking up the keyboard with no driver.

Additional info-
I wasn't sure about the sata cables, they are sata3.. People said that didn't matter and they are BC. My monitor is hooked up through HDMI (i know both the monitor and cable are good)

My specs:
Asrock z77 Extreme6 mobo
Gigabyte GTX 670
Gskill 8GB 1600 ram
i5-3570k
850w PS

Any help would be greatly appreciated. I'm building this computer for school (DMA) and only have a week before I am really going to need it. That was probably stupid on my part.
Let me know if you guys need any more info.

Best solution

a b Î Nvidia
January 15, 2013 4:38:15 AM

Okay so do you already have the operating system preinstalled are you trying to install it what are you trying to do. My motherboard very similiar I'm sure bios wise is a ASROCK z68 extreme4 gen3 and I had to set my hard drives to AHCI to get it to function properly. SO that may be a start and then I would set the boot device to the cd drive or flash drive if you are installing the os that way and install the os. What brand/ model is your psu.
Share
January 15, 2013 4:45:40 AM

Also directly after the Asrock screen, it flashes a screen very fast and then goes blank. So fast i had to video tape it and pause it to read it. It says "copyright 2011 american megatrends.." ect.. It recognises the mobo im using, it registers all of my ram and my CPU. Then it says " UEFI defaults have been loaded.
press f2 or DEL to run setup
Press f1 to continue"
then it goes blank.. Hope that helps a little..
Score
0
Related resources
January 15, 2013 4:46:18 AM

I have windows 7 64 in the dvd drive. Nothing has been installed.
Score
0
a b Î Nvidia
January 15, 2013 4:46:47 AM

turn your pc off for now and unplug it from the wall. let the mb drain then remove the gpu for now. you want to try and boot from the onboard video and see if you can get into the bios. (make sure your blue tooth on the usb 2.0 port). if you cant get in try clearing the cmos so that the mb has to go into the cmos and reset itself or see if someone has a ps-2 keyboard.
Score
0
January 15, 2013 4:47:40 AM

I have a corsair HX850 PSU. I don't think im able to get to the bios screen to change the boot settings..
Score
0
a b Î Nvidia
January 15, 2013 4:50:44 AM

If you get to the logo screen keep pressing delete that is the key to get into the bios at least attempt to.
Score
0
January 15, 2013 4:55:09 AM

Ok, I found a keyboard and it got me into the bios screen. What now?
Score
0
January 15, 2013 5:00:25 AM

Thanks guys I got it to the windows screen. HDD was set to ide, thanks bigshootr
Score
0
January 15, 2013 5:02:47 AM

Best answer selected by DCNo07.
Score
0
a b Î Nvidia
January 15, 2013 5:05:54 AM

I apologize I just restarted my computer to take a look at the bios to kind of get a feel for it.

You want to go to advanced>storage options>Set SATA MODE SELECTION to AHCI

Then move onto the boot tab

You can set your hard drive priorities if you have more then one HDD you didn't list your setup in that area so i'll let you set it up that way. Set boot option 1 to your CD/DVD Drive your motherboard should pick up the particular drive so you can select that.

Click Exit
Save Changes and Exit. Your computer will turn off and then it should turn back on.
Score
0
a b Î Nvidia
January 15, 2013 5:06:53 AM

Oh you figured it out :)  good snikes man WOOT! Yea I had a feeling it was set to non AHCI :p 
Score
0
!