Sign in with
Sign up | Sign in
Your question

PLEASE HELP. assassins creed 3 artifacts hd 7950

Last response: in Graphics & Displays
Share
January 15, 2013 11:07:09 AM

Today assassins creed 3 has got serious graphical issues with my xfx dd 7950. Artifacts and lines everywhere! My other games like farcry 3 are all fine, Ive uninstalled the game and reinstalled and im still having this problem! Ive removed all amd display drivers and reinstalled to no avail. The issue occurred after a game crash due to assassins creed not liking my O/C on my card. I was trying to find the sweet spot like I did with farcry 3 when it didn't like my O/C. It was only a small O/C for my card 1000mhz core 1350 mem. factory on my card is 800mhz 1250. :cry: 
January 15, 2013 11:32:56 AM

did you try setting the OC back a bit?
January 15, 2013 11:49:32 AM

mansfield said:
did you try setting the OC back a bit?

Yeah mate. I put it back to stock and its still messed up.
Related resources
January 15, 2013 12:01:10 PM

well that's weird since you said other games are fine. maybe you're card doesn't like one of the graphical settings inside the game. only thing I can think of.
January 15, 2013 12:08:08 PM

Did you try installing different drivers?
January 15, 2013 12:13:47 PM

strider_18 said:
Did you try installing different drivers?

I reinstalled beta driver and cap 2. I just run unigine and got the same results as my last run a couple of weeks ago so would you say its not my card? When when i uninstalled ac3, I kept saved games and profile stuff. should I uninstall them and try?
January 15, 2013 12:16:03 PM

mansfield said:
well that's weird since you said other games are fine. maybe you're card doesn't like one of the graphical settings inside the game. only thing I can think of.

AC3 was working fine for around 2 weeks b4 this issue. when I uninstalled the game I kept profile and saved games. should I have uninstalled them in case the issue has stayed in them?
January 15, 2013 12:18:37 PM

if you don't mind losing your saves, that might be the problem but sounds unlikely.
a b U Graphics card
January 15, 2013 12:45:08 PM

You could try this:
Go to your games installation folder, select your game launcher (AC3SP) Right-click it and go to properties. Select the compatibility tab and select the checkbox "Disable display scaling on high DPI settings".
Otherwise post your graphic settings from the text file found in:

C:\Users\{your username}\Documents\Assassin's Creed III

But yeah I think if you choose to save your profile you also save the graphic settings from that profile.
January 15, 2013 1:59:37 PM

Mahisse said:
You could try this:
Go to your games installation folder, select your game launcher (AC3SP) Right-click it and go to properties. Select the compatibility tab and select the checkbox "Disable display scaling on high DPI settings".
Otherwise post your graphic settings from the text file found in:

C:\Users\{your username}\Documents\Assassin's Creed III

But yeah I think if you choose to save your profile you also save the graphic settings from that profile.

Your a star! Checking "Disable display scaling on high DPI settings", has worked. Please could you explain to me what checking this has done to hep my problem? I hate not understanding what things are and not knowing about an issue. Does this lower my game settings in any way? Do you have any of these following games, hitman absolution, sleeping dogs, farcry 3. I have a spare code for them games and was going to sell it for £10 but out of thanks I'd like to give it to you. If you already have them games though ill bless someone else the next time I have a problem.
January 15, 2013 7:29:18 PM

glad you found a way to fix it! would have never figured that out lol.
!