Sign in with
Sign up | Sign in
Your question

Atheros AR928X Wireless Network Adaptor NOT WORKING

Last response: in Wireless Networking
Share
February 13, 2012 5:22:45 PM

Hi all, this is my first post so I'll try to be descriptive as possible...

I have an Asus M50Vm laptop

Specs are as follows:
Windows 7 Ultimate 64-bit
2.26 P8400 GHz Intel Core 2 Duo
4 GB DDR2 400 MHz RAM
NVIDIA GeForce 9600M GS Graphics


And of course, the Atheros AR928X Wireless Network Adaptor.

It seems that no matter what I do wireless capability cannot be enabled.

I tried turning the wireless capability button on and off but to no avail. Then I pressed FN+F2 and it didn't fix it. In both those situations a box which displays the status of the wireless LAN connection comes up, however, it reads "OFF" regardless of me performing the above two "fixes." According to my computer the card is enabled and I tried uninstalling and reinstalling the device driver but nothing changed.

I'm unsure where to go from here.

Any help is appreciated.

thanks
February 13, 2012 5:25:36 PM

oh and I can access the internet via Ethernet cable from my router
m
0
l
February 13, 2012 5:36:35 PM



Hello and welcome to Tom's Hardware Forums.

Have a look in your BIOS menus to make sure that the wireless adapter is enabled and that you don't have a setup that allows wireless or ethernet but not both.


m
0
l
Related resources
February 14, 2012 4:57:01 PM

Thanks Saga Lout.

That did fix the problem for a few hours but as I noticed the connection acting buggy again (even though the router was working perfectly) I ran the troubleshooting option and now I'm back to square one. If it helps I noticed the wireless adapter lost connectivity after the troubleshooter reset it.

I checked the BIOS menus and they were unchanged (what originally fixed the problem was switching the "Onboard LAN Boot ROM" option to ENABLED.

I can access the internet via ethernet now and interestingly, when I turn off the wireless connectivity switch and turn it on the message displayed on the screen reads "Wireless LAN OFF" but bluetooth turns back on every time.
m
0
l
February 14, 2012 5:01:50 PM



Is it set in Device Manager under its Power Management tab to allow itself to be turned off to save energy?

m
0
l
February 14, 2012 11:17:58 PM

Problem solved. I just had to press FN=F2.
m
0
l
!