NVidia driver not loading

Hello

I've had this problem twice now, once today and once yesterday.

When I booted the PC up, the nVidia driver (I have a GTS 450 by the way) couldn't be loaded by Windows. I reinstalled the drivers, rebooted, and everything was fine. The same thing happened again today, and reinstalling the drivers worked again.

What's causing it? I'd rather not have to install the videocard drivers every day. I've also recently got Empire Total War, but surely that must be a coincidence?

I'm also starting to think now that the GPU drivers are what was causing the computer to crash.

Could the GPU need replacing? I've got some cash now and was planning on getting a new motherboard, my current one is too crippled, but if a new GPU is needed I'll get that.

Is a clean install of Windows in order?

Thanks for any help :)
4 answers Last reply
More about nvidia driver loading
  1. Hello... a re-install would be an economical fix... there are multi-media components to video cards these days, and multi-drivers that need to be installed... involving multi Windows re-boots to get them all properly installed.

    Is this a new or existing Video card?

    What windows version?

    Where you getting your Drivers?

    Completely remove your old drivers and program?

    Try an older version from the NVIDIA site?
  2. I've had this card since 2011, so it's not new, I'm using Windows 7 Home Premium, I'm getting the drivers off the nvidia website. I didn't completely remove the old drivers, Windows couldn't load any. I haven't tried an older version either but some of my games won't run on the older drivers so I'd rather not try an older version.

    Annoying thing with the reinstall is the tons of downloading I would have to do. TF2 is a good 8 gigs larger than what it used to be, and for some reason Empire Total War wouldn't install off the disc, so that was a 10 gig download too. But if it fixes the problem I'll have to do it. Would sysprep fix the problem without the need for an reinstall? From what I've read it makes Windows 7 remove all the drivers, but keeps the programs.

    Also something interesting just happened today. I booted it up, and the drivers were loaded. Yesterday I didn't play Empire Total War, whereas I did the days before the drivers not loading. So one would assume that the game is causing the issues? Why would the game be causing that?
  3. I had a similar problem with my GTX 580 cards (I have two). When I booted up in the morning, one of my cards was disabled. I reloaded the driver and it was fine.
    I tried older drivers and on soft boots (restarts) the drivers were fine and both cards were in service. But the next morning, after I powered on the PC, one card was disabled.

    I did three things that solved the problem completely. I think the first one was the real solution but I am not sure.


    I hope this works for you, too.
  4. I found out what was causing the problem soon after I posted this. It was gamebooster that was causing it, as when I ran Empire Total War without gamebooster the issue was solved. I've got 8 gigs of ram now so I no longer need gamebooster. Thank you for the help though :)
Ask a new question

Read More

Nvidia Drivers Graphics